Bad Logging on Pixhawk1

Hey Everyone,

Requesting a little help to identify what is cuasing a logging issue. I am using an orginal pixhawk 1, loaded with copter 3.5.rc5 and have had some logging issues.

Prior to today’s problem I had another bad logging incident. Last time, I reformatted the SD card. Didn’t work. Then replaced the SD card with one from another pixhawk controller. Didn’t work. I reformatted the second SD card. Didn’t work. Finally I replaced it with a brand new San Disk 8gb card. That seemed to work, until today.

Today, everything looked good initally. About 1/3 of the way into the flight I noticed a bad logging que in the hud. Upon landing I expected not to be able to retrieve any logs. But, to my surprise, I was able to retrieve what was logged. Not sure why I can read it but couldn’t write to it. The card is mostly empty, with the exception of today’s flight. I delted all the other log files yesterday.

I use the log files to geo tag my images and would like to know what is causing this problem. Everything I’ve read says it’s a bad SD card, but this was a brand new card with less than a dozen flighs on it. So I suspect something else is up

Any ideas?

Here is a link to the log file from today’s flight.

The vibes looked ok and can’t think of anything else to look at.


do you have a higher speed/quality SD card to try just to rule that out?

I was having a variety of weird logging issues. I replaced the micro sd card that shipped with my pixhawk clone with a brand name, freshly purchased card, and all of my logging problems disappeared.


That initially worked, but was short lived.


I am using a 8gb San Disk, class 4 speed, 4MB/sec


ouch, class 4? I didn’t even know they still make those! Definitely get a faster card. Class 10 is industry minimum for pretty much everything these days.

Finally flew after replacing the micro SD card with a class 10 card. Worked for a few flights then started getting a bad logging message. I’ve replaced the sd card 4 times. Each time it works for a few flights then I get bad logging. So I suspect something in the pixhawk is causing the logging. Anyone have any ideas?

In an attempt to definitively solve thiis problem I swapped out the flight controller with new pixhawk 1 from 3DR. Did three test flights: one in loiter and the other two auto missions. The auto missions took 25-35 pictures. All three flights went fine with no indications of bad logging. Yesterday, I flew an auto mission that was supposed to take 135 pictures. Around the 85 picture we go a bad logging message flashing in the HUD. This seems consistent with previous logging issues - it happens durning longer missions.

We are using a Septentrio AsteRX with a VRS correction leading to a fixed solution. We are beginning to think the Septentrion is somehow causing the logging errors on longer flights. Could this be possible? I intend to do two identical auto missions; one with board connected and one with it disconnected.

Related Info:
I have the AsteRX set as GPS 1 and the standard 3dr GPS as 2.

Any insight is apprecated.

Thank you,

Did you ever get this solved? I am having the same problem using hot shoe trig set up. Without the trig message it works fine, but with it on, it might last a few short tests and then it goes to bad logging. I’ve used a couple cards that have never given me problems in the past, so I rule that out, and it doesn’t happen when the trig is turned off.


No, unfortunately, I have yet to solve this problem. Just yesterday I got a bad logging message the moment I armed the aircraft. I flew the day prior with the same set up and had no problems. The problem is highly intermittent. One day it works the next day it doesn’t. I have had no luck trying to isolate the problem. On our quad I don’t think it’s related to the hot shoe. Hot shoe feedback is something we just started using and we had this problem for nearly a year, spanning copter 3.4 and 3.5. I have had the problem with no gimbal and no camera. The only thing I relainjgn thing I need to try is formatiting a high capacity 2gb ad card with FAT instead FAT32. I’ve exhausted all other ideas and suggestions.

Sucks! We need the info for geotagging.

Wish I had an answer for you.


Same problem that never I had before (last 4 years with the unchanged setup)