Bad Logging / LOG_DISARMED = 1 / no CAM/TRIGG logs

Hi all,


  • Testing camera hotshoe feedback
  • Pixracer


  • Both CAM and TRIGG messages are not logged
  • Both CAM and TRIGG messages appear in the FMT messages
  • Mission Planner reports “Bad Logging” (see screenshot)
  • Mission Planner shows the CAM locations generated with hotshoe feedback (see screenshot)

I haven’t tested LOG_DISARMED + CAM + TRIGG before so it might be normal but since there is a Bad Logging message I assume it is not. I rebooted several times but still no CAM or TRIGG messages in the log.

Best regards,

Until the logging failed message is gone there is no point looking elsewhere. Check your SD card, format it if needed.

There actually can be Ardupilot issues - especially with pre-release. It’s not -always- our equipment, peripherals, other’s equipment or other’s code that cause the issue. That’s not to say it couldn’t be the sdcard,

This is Oxinarf’s typical response, and it’s troubleshooting done backward - and in my personal experience is rarely, if ever, helpful, or productive. Sorry, but it gets old both getting this response and seeing it given to others.

Try deleting the last log file. If you can list the folder in Windows or whichever OS you’re using and delete the file…it’s a good chance it isn’t the card.

You don’t have log_backend_type set to 0 do you?

I’ve had this happen on a failed xfer due to conneciton loss during xfer dataflash over mavlink, Although it was solved by a power cycle reboot.

I’m just assuming it a) worked before and b) you’ve been changing the logging parameters, so it’s a good possibility another setting was inadvertently or intentionally changed.
Especially if using the “full parameter list” in Mission Planner, a click in the wrong place, or a mouse wheel movement in the wrong place can change something unintended. I tend to use the full parameter tree if I can to minimize that chance.

If those don’t work, -then- maybe try another sdcard.

@Lance_B thanks for your suggestions! However, no unintentionally changed parameters or something.

@OXINARF thanks a lot as usual for providing the solution! Much appreciated!
However, this is rather strange - to me. I had no problem with logging on this card/Pixracer so far. All worked but CAM and TRIG logging. After several tests I decided to format the card again. Now it works…

NuttX (the OS below ArduPilot in Pixracer) has mysterious ways of working :smile: I’m glad it’s fixed!

Hi Francisco,
I am getting the Bad Logging message again. However, there are no problems with CAM and TRIG messages any more.
So, I changed the SD card and formatted the new one before testing it. Still I get Bad Logging messages.
Any idea or suggestion?
Thanks and cheers,

Well, my fault I guess… After some systematic tests I am pretty sure it is related to downloading logs while having LOG_DISARMED is set to 1. Makes sense… Sorry for the confusion!


@Thorsten you only get a problem if downloading the current log right? Or downloading previous logs also give you a problem?

@OXINARF, I also get it when downloading a previous log only. Just tested it again.

Ok, thanks. Another question: does the SD card get into a bad state (so you always get Bad logging message) or does it happen only while you are downloading logs?

Not 100% sure yet. But definitely in most cases (not all) when downloading a log.
I’ll reinstall the firmware and make further tests.

Ok, the message while downloading a log is (as our dataflash master @peterbarker wrote) if-not-as-designed-then-as-known. If you have any other reproducible cases let me know.