Bad logging after enabling scripting

I encountered a problem, where I get “bad logging” errors if I enable scripting and run a very simple lua script. Has anyone else encountered this issue?
CubeBlack running V4.0.3

I tried the usual formatting the SD card, changing some of the logging and sd card parameters without solving the problem.

You are lucky, my cube black if i enable scrpting doesn’t even download params anymore. I asked if maybe the arm in the cube black is a little on the edge for enabling lua scripting but didn’t get an answer yet.
Mine acts strange on both black cubes i tested it on.

and if you enable scripting without running the script?

Will “hello world” do as a script to recreate this?


As soon as i enable scripting the board doesn’t go past loading parameters in MP, never had an opportunity to run a script.
It stays in “already got param” loop forever.
Already asked if there is a known prob with cube black but no answers, so i guess there is a problem with it :slight_smile:

Scripts are not recommended for F4 processor autopilots. Last time I tried, it worked after disabling terrain follow and one of the EKF.
Try autopilot with H7.

Ah ok thanks, i must have missed it when i read the wiki on scripting. Will try them again once i get an orange cube, once the parameter erasing stuff will be solved.


1 Like