Servers by jDrones

Bad LIDAR health with several different LiDARs

arducopter
pixhawk21
lidar
rangefinder
sonarrange

(petros) #1

Hi,
I have tried connecting several different LiDARs to my Pixhawk 2.1 via serial but i keep getting the same issue: Bad LiDAR health and no readings.

LiDARs i have tested are Lightware SF02, Lightware LW20, Benewake TF03. I have also tried the CAN option for Benewake with little success.

I have double checked all connections (reversing both tx/rx) and have tried powering both from Pixhawk and from external power source.
I have also double checked all necessary parameters incl.
RNGFND_TYPE
SERIAL1/2_BAUD
SERIAL1/2_PROTOCOL (tried both telem1 and telem2 ports on the Cube)

I have read from an old forum post to check the RNGFND_LANDING parameter but I believe it has been removed from newer versions of AC. I also tried going back to AC3.3.3 and AC3.4.5 and testing but with no success.

I am currently stumped and not sure how to proceed, any help would be greatly appreciated!


(Brian Riskas) #2

I have found that if you are powering the LIDAR on at the same time as the pixhawk 2 that you will get the ‘bad LIDAR health’ message you are seeing. Try powering the cube via USB, then powering the lidar and see if the message goes away. In my case, I had to add a time delay relay between the lidar and the BEC to allow the pixhawk to power on before the lidar, and avoid the bad lidar health message.


(petros) #3

Thanks for your message. I dont think that is the case here however as I am connecting the LiDAR whilst I already have the Pixhawk connected and running on my laptop via USB.