"Bad LiDAR Health" when RNGFND_LANDING=1 for autoland


I’m using the WASP 200 lidar, Pixhawk 4, and the latest arduplane firmware.

I’m getting the error message “Bad LiDAR Health” when RNGFND_LANDING = 1 which is what it’s supposed to be for autoland.

When RNGFND_LANDING is equal to 0 I don’t receive the error message but that means the lidar isn’t enabled for autoland anymore. Usually, the “Bad LiDAR Health” message happens when its set to 0.

In either case I’m getting accurate sonarrange data readings.

The distance ranges I’m measuring are within the max and min distance of the sensor.

Has anyone ever seen this before? Any help? Thanks

Are you powering up the lidar from a BEC or from the pix?

From the pixhawk serial 4 port. Do you think it’s not getting enough power? Is there a way to tell?

its all about amps. The pix board is not made to deliver to much power. I had a similar isues, in my case, I had 2 TF mini, and at the moment of takeoff, the cube rebooted himself. In another case I couldnt do the compass calibration because when one of the TFmini went far to measure, make the calibration fail.

In general, we only energize the GPS and no more accesories from the pix. Every external device must be powered by a 5 or 12V BEC.

I think this will be your solution, im very sure. Try it and let us know.


Hey Alberto,

The lidar can take 5-16V so I connected the lidar directly to the 3s battery and it’s still giving me an error when RNGFND_LANDING = 1 but not when set to zero. This is the exact opposite to what everyone else is getting for an error. Was there a software update that made this parameter obsolete or something… :S

I also tried connecting it to the 5V being supplied by the ESC, no luck.

ok sorry to hear that…

Anyway, take the power to the lidar from an external powersource, not from the pix.

You can have a inflight reboot if you keep your setup.

Let us know when you figure it out!



Flew with the LiDAR and tried autoland with RNGFND_LANDING set to 1 and 0. In either case, looks like like only the BARO altitude is being used for landing. Out of desperation I purchased a Benewake TFmini to try and it works! No error message and LiDAR range is being used during landing.

I still really want to get the WASP200 working because I need the range. Does anyone know what are the things that trigger a “Bad LiDAR Health” message in the code???

I’ve contacted Attollo Engineering to see if they have experience fixing these things. We’ll see what happens :frowning: