Servers by jDrones

Bad Lidar Health using a lidar through a raspberry pi

Hello, I dont know how to work this issue, I am using an rplidar a3, which has a stability mode that can work fine during the day, I have also written a code so I can on the raspberry pi send out data which is reliable, and using a mavlink message for sensor_Encode i send the distance in centimeters and the corresponding sector, now inside a house static works fine , but in mission planner I do not see any red circles around the drone or anything, the moment I take it out outside, it just says bad lidar data and disarms , or arms and disarms constantly and i see a bunch of red circles in the map.

I have set oa_Type to 1 as I want to use bendy ruler and have set up most of the parameters to ensure communication. now I am seeing the data I am sending in my rapsberry pi, and the distance is similar minus a small difference in readings for sectors , but I always send around 1 data reading per sector each 0.08 seconds so I am thinking this might be the issue. Is there a way to disable the bad lidar health check? I am using rover si there is no rgnfnd_landing parameter at all .

here is an example of data I am sending, for each array , as soon as its printe,d it sends 1 data per sector and then reruns. Inside the house where of course there is less deviation its having no issues or bad lidar health messages.

I think i found out the issue being the delay between sending data? I tried sending data at 0.01 second, random data , and it removed the message, but if going above 0.5 , I just get a bad lidar health that goes on and off randomly… Is there a way to change this behaviour? my code will send 8 data packets in intervals that can range from 0.3 to 0.8 seconds depending on the number of reliable datapoints. That means that each 0.3 to 0.8 seconds I will send 8 data packets each one in less than 0.1 seconds. is there a way to change the way that the pixhawk activates the bad lidar health?

Servers by jDrones