Servers by jDrones

Bad Day for my new model altitude and pitch problem

Hi good evening at all, good day for fly but bad day for my new model
SetuP
Radio Crossfire
Tx video 1.2 Matek
FC F405 wing new
Model Mini Talon
4 Analog servo
Cam Runcam Split (died)
Motor sunnysky
Battery 4S2P 21700 5000mah

everything went well at take-off no problem the model looked well leveled and responded to the controls, I performed the first turn right in the middle of the straight I noticed that the model in FBWA began to hit not remaining level, I made a second turn towards my flight field and convexly the model also beat with gas, I put the model in manual and everything seemed to be fine. unfortunately not wearing glasses I could not see artificial horizon rotating, putting the model back in fbwa unfortunately everything came to life. I’ll put logs and videos on it. recovered the fc model was still attached to its base was not detached repairable model is not the first model I do, but the first problem of this type. I noticed in the osd video that just after launched I have an imu usage message. also a height overhang.

drive link to osd video and log file

https://drive.google.com/drive/folders/1dMc9EwF0NvF2CIikiXCcBqwlKLtr44_L?usp=sharing

thx for your help

your plane seemed to perform well just after launch, but you

  • launched with your EKF not settled, likely due to
  • all arming checks other than GPS fix disabled, presumably to mute arming checks for
  1. compass (enabled but none connected)
  2. airspeed (enabled but none connected)
  3. terrain (enabled but not used)

launching with your EKF not ready introduced a critical attitude and altitude error inflight. judging from the performance right after launch you might have easily saved it by switching to MANUAL, which you did at the right time, but after that you pulled too much up elevator with too little throttle added and finally stalled the airframe into a crash.

  • set ARMING_CHECKS to 1 (= all, default)
  • solve arming issues:
    1. if not using a mag, set COMPASS_ENABLE and COMPASS_USE to 0
    2. if not using an airspeed sensor, set ARSPD_TYPE to 0
    3. if not using terrain following, set TERRAIN_ENABLE to 0

the model was on and stationary on a table waiting for the fix and checks for at least 3 minutes, after the fix we double-checked commands and responses before launch. From the video you can see that from min 0 to 25 if when I took off gas the model beat more and more and I corrected with the stick. the turn was made at 50Kmh with 45% gas against wind, at sec 33 the height on osd went from 77 to 518 meters. if you notice artificial horizon had already completely gone off axis. got out of the turn the model heavily beat not by stall, I was still in fbwa, at 102 km/h, at sec 44 I put in manual since in fbwa he was beaten to the maximum and in fact the model gave elevator at 170km/h. after the cabrata of the passage from manual the model went to 80km /h had not stalled in the video we are at the 51st in manual the model was fine my error was to put it back in stabilized to land … at the second 54 with fully gone horizon, but I could not see it being in open flight, but the board led the plane to stall. before this the manual speed was 56km/h as soon as I passed in stabilize the board corrected with elevator and giving ailerons making it screw. the model would not have stalled if I had maintained the manual controls but at that moment I opted to re-establish it.

the model don’t have Comapass, airpeed and terrain…how is possible have to default all sensor active if this are not present on the model??
the GPS fis are all time checks before all take off…

i think the board of firmware have some problem

Servers by jDrones