Bad compass issues

I just bought a Pixhawk kit from mRobotics, my 2nd one from them. It comes with their Ublox GPS/compass unit as well. I have the Pixhawk and GPS/compass unit taped to a piece of cardboard to maintain their orientations for bench testing.

The compass calibration seems to go okay, although the numbers seem high. I tried both the onboard and live calibrations with similar results.

After the calibration, I’m still getting a lot of “Inconsistent Compasses” and “Compass Variance” errors.

I can load the EKF status window and slowly yaw the system and watch the compass EKF go off the chart relatively quickly.

Any suggestions?

The offsets of your compass are too high.

  • Try Onboard Mag calibration
  • Disable Internal Compass

If this will not solve the problem you might have a problem with the I2C bus .

What is the batch of you Mrobotics Pixhawk (it is written on the PCB ) ?

Had this same problem today.
Turning off internal compass completely fixed it.

But is it a good idea to disable them?
I mean aren’t internal compasses designed to be back up?

Not really , since internal compass is widely unreliable it often gives readings that are contradictories compared to the one of the external compass .
The point is that if the difference between the two compasses becomes too big , then, EKF do not know which compass is right and so it display an error