Bad compass error. I am clueless

im sorry to sound like that guy but i am so lost. i have spent months on this thing and im so close to being done with it i am starting to get annoyed because it feels like all my work has been for nothing.

so i really have no clue what to do next. my build is a s550 hexacopter. pixhawk, with raspberry pie running uavcast over 4glte. i got all that set up and running but now when it comes to me flying the thing i have no clue how to do that. i have no clue what to set the parameters too. ive read so many forms i feel my eyes are going to pop out of my head. i keep getting “bad compass” errors. i cant even get it to fly in the simulator. im so stressed over this build but i dont want to quit yet. not since im this close.

please any help would be appreciated so fricken much.

You need to make sure the compass is correctly connected, an then calibrate the compass outside, with clear sky view and GPS good GPS reception without any metal structures around you.

With the default parameters do compass calibration in relaxed mode. Tell us more about your hardware. What version of ardupilot you are using? Also some bin logs with log_disarmed=1.

Or at this stage just a parameter file may do. Do you have an RC system?

took it out side calibrated it and got it to calibrate finally. i bring it inside and get…
11/20/2021 4:24:14 AM : PreArm: Bad GPS Position
11/20/2021 4:24:14 AM : PreArm: Compass 0 not Found
11/20/2021 4:24:14 AM : PreArm: Compass not healthy

to be expected… because its in side right?

hardware: radio link pixhawk. (no cube or anything fancy yet) 2212/920 kv motors 30 amp esc. gps mounted up on pedestal. running a raspberry pi 4 8gb ram with 4glte service transmitting and recieving telmetry data through UAVcast from mission planner. im running ardupilot 4.10 (newest one non beta)

are you asking me for a param file? if so where would i be able to find you a copy of my param file? or u suggesting i just download a fresh complete param file? if so would u recommend one based on my set up i displayed in the other comment to the other user. do i have a rc system? yes i do. its a rc controller with telm module mounted on the drone. i have a fs-ia6 and a flysky rc controller i had set up on here b4 i switched to the 4glte set up.

to answer the wonder if it comes up, no i have never had this bird in the sky. i bit off a huge bite with this one i know but i did take my time with the whole build. thats why i just thought i could atleast try it out with the simulator b4 anything. but i am still having no luck with that. thanks everyone for the help so far.

You need to download the param file from the vehicle.
And ArduCopter 4.1.0 is not the latest stable, the latest stable is ArduCopter 4.1.1

Yes, from the Full Parameter List in Mission Planner, Save To File. Forget about LTE until get it configured and tuned. There are plenty of Wiki Guides for this.

i followed the wikis till my eyes bleed and kept having no luck so thats why i went to a different route because i couldnt figure it out. could you give me any idea where to start?

Start by posting the Parameter file here. You can simply attach it.

trying to figure out how to do that now.

hexacopter_parameters_file_1.param (16.7 KB)

There are no compass’s being recognized. If there were there would be ID numbers here:

Beyond that most is at default so you haven’t done the Initial Tuning before 1st flight. This is in Mission Planner. Setup>Mandatory Hardware>Initial Parameter Setup. If you don’t see this update to latest Mission Planner Beta using the button on the bottom of the help screen. Plan on updating Beta regularly.

ive gone through all the initial manditory configurations and calibrations time and time again. some times it will let me calibrate compass and other times it will not. some times it will let me do it indoors and most of the time it wont lol. Butttt today I uploaded the new 4.11. it is now just flashing a blue light saying bad bettery on MP. so i have a battery on the charger while im looking for my small 4s i keep on hand for little things. will update what i find out when i try out the new battery.

question!! now after i complete the manditory set p, how do i save them? like i said i have done it quite a few times, what do i need to do so tat i know it successfully saves to my FC

You should never do the calibration indoors. There it is obvious that it will fail, so why trying it???

By following the instructions (badly) multiple times, you will only frustrate yourself. It will not get you better results by doing it badly multiple times.

To avoid frustrating yourself, do it correctly. Then you only need to do it once. :slight_smile:

Once you calibrate it and click “write params” it gets saved in the FC. No need to repeat it unless you change something in the vehicle.

now does it have to be conected to my lap top via usb or is udp or tcp connection acceptable?

and under the “full list” is where i click write params?

went to plug in my 4s lipo like i have done time and time before. well now im getting no power to my flight controller. i do have a circut protector that prevents over current from frying components. but i dont think it hasanything to do with under current? i thought it was weird last time i had everything plugged in i lost power to my raspberry pi but my pixhawk was plugged in via usb to my laptop. so that never lot power. everything works as it should except when i rely on power from my lipo. i get no power no where. i ruled it out to be a faulty power module as i am getting no power to my pcb. is that a common known problem that low voltage will cause a power module to give out??

edit the circut breaker device i have quit working on me. im assuming it shorted out due to low voltage.

okay so now when i enter my voltage in mission planner it does not save?? is there any special way of getting it to save?

as for inital flight, i keep getting pre flight check failurer “bad compass health”. even though i have it out side clear skys and all that jazz. any suggestions? i am getting positive reading that im picking up the proper amount of satilights

Where and how are you “entering the voltage” in mission planner?