Bad Channel 1 Input

I have been having issues connecting my Taranis X9Plus to communicate with my Blue Robotics T200 thrusters. I have the Blue Robotics ESC’s connected to the thrusters on one end, and the servo signal connected to ports RC5 and RC6 of the autopilot. This was done in hopes of being able to drive our 3D printed catamaran using differential steering, but have not been able to talk to the autopilot to send commands.

I am using a pair of RFD900x radios to establish a connection between my laptop and my pixhawk autopilot. Thus far, I have been able to pair my RFD900x radios successfully to one another (solid green lights), and can connect to Mission Planner via my RFD900x usb connection. My FrSky D4R-II is successfully connected to my Taranis.

The issue I am facing now, is that I am not able to calibrate my radio. The bars in the Radio calibration window are blank, and will not change regardless of the parameters I have set for both the Thrusters servo connections. When I try to calibrate the radio, I get the error window stating “Bad Chanel 1 Input, cancelling”.

Can someone please help me establish a connection with my boat rover? At this point, I don’t know if I am missing parameters, haven’t set up my Taranis correctly, or have a bad board. Any advice on how to setup the Taranis controls as well would be greatly appreciated. I have not been able to find anything helpful for my application.

I have setup channels 1 and 3 to do differential steering on the Taranis but can’t see the throttle changing on mission planner.

If anyone has any good advice, I would greatly appreciate it!
I have gone ahead and attached drive link with my current params, as well as a few photos showing the setup of the electronics used for this rover.

https://drive.google.com/drive/folders/1Ebgnz7-DQG2rpaRDq8hiRVqtjkZhuaIG?usp=sharing

Hi,

please start with reading the documentation:

https://ardupilot.org/rover/

Disable all mixers, dual rates, expos, trims in the Taranis. Best start with a new model.
The D4R-ll receiver needs a jumper over channel 3 and 4 to enable ppm output on channel 1.

@count74

Thank you so much for the advice! I created a new model on the taranis, and put a jumper over the channels 3 & 4 as suggested. I am now able to control the T200’s.

The issue I am having now is the controls. I have throttle setup on my left stick, and left/right turns on my right stick.

When moving the right stick in the left direction to make a turn, the left motor stops completely and the right motor speeds up significantly. When I move the right stick in the the right direction, the same occurs (left motor stops completely and right motor speeds up). I would like to be able to make left and right turns on the water, is this a parameter that needs to be changed? The link you provided for the rover does not cover any other parameters other than the throttle left and throttle right.

after a minute of running them, they’ll just stop and my buzzer will start making a ticking sound even after I power the entire system off. Could you explain to me what is occurring?

I read the rover documentation and set up skid steering params (73 and 74 on the corresponding ports 1 and 3 as suggested in the doc). Thank you in advance

A parameter file and/or a bin log would be helpful. Are you sure there are no mixers enabled in the Taranis?
Is the left stick on your Taranis spring centered? Even though MP tells you to pull the throttle down at the end of radio calibration, it needs to be in the middle for ardurover.
To make things easier, I always try to setup my rovers to go forward with PWM values greater than 1500us and reverse with values lower than 1500us. This is to make sure I do not need to invert any channels.

1 Like

The param file was included in the google drive link that I attach in my first post. I can add it again in this post for you to check out!

The left stick on the taranis is centered. When pushed all the way up, the autopilot arms itself and then the motors begin to run.

When pushing the left stick up, the Mission Planner Radio Calibration tab shows the Pitch bar changing values.

I created a new channel setup. Throttle to ch 1 and AIL to ch 3. I’ve attached a picture of what my controller is currently set to (it drives forward but will not turn left or right)

Not sure how to setup these controls correctly to allow me to make drive forward backwards, and make left and right turns

https://drive.google.com/drive/folders/1Ebgnz7-DQG2rpaRDq8hiRVqtjkZhuaIG?usp=sharing

Hi @jogalindo,

I guess the issue here is the RC setup and getting the RC calibration done.

RC calibration described on the wiki but in any case, when you move the two sticks around the green bars (on MP’s Radio Calibration screen) for roll, pitch, yaw and throttle should move.

The throttle channel will (eventually) make the boat move forward/back. The Roll channel will change its direction… so these two channels are the most important and if you don’t like the stick that is controlling these two channels you can change it in the transmitter somehow I think. For the throttle channel you should use a stick with a “sprung throttle” as they say so that it returns to the middle when you release it.

… so after you’ve got the stick to channel mapping as you like it, next check the direction. All the green bars should move in the same direction as the physical sticks except for Pitch which moves in the opposite direction (sorry, that’s just how it is). If the green bars move in the wrong direction from the physical sticks then change the reverse setting in the transmitter (don’t change teh “Reverse” check boxes on the MP screen… leave those all as unchecked.

You should also setup the transmitter so that a three position switch controls channel 8. This will be used to control the “flight mode”.

Once all the above is done, push the Calibrate Radio button and move all the sticks around. At the final stage of the calibration remember to move the sticks back to the middle.