Bad baro health

log_0_UnknownDate.bin (282.6 KB)
Hi my log here

This is a known issue in master/most recent RC. When CAN is enabled it is always looking for a CAN baro sensor. If you were to set BRD_CAN_ENABLE 0 it would stop warning you. is intended to fix it, I’m not sure if it will make it to a 3.5 backport or not, that will need comments from @rmackay9

1 Like

I set BRD_CAN_ENABLE to 0 and it works.
Many thx

1 Like

Great, we will add the permanent fix into -rc8.


hello may be there is an issue on this.

I am using Zubax GNSS 2. And i need to enable UAVCAN and set the parameter BRD_CAN_ENABLE to 2.

Yesterday I upgraded my pixhawk to 3.5-rc8 and it coud not get GPS FiX… (external compass as well…)

I tried to troubleshoot for couple hours but i did not succeed.

So I decide to downgrade to latest version 3.4.6. It works fine.

Need more investigation. Unless you are already aware of this issue. and procedure for Configuring Zubax GNSS 2 with Pixhawk would have change…

Alexis, you might solve looking at this post :

Thanks. Sounds good. I will correct. And let u know.
Once again i do beleive thet zubax gnss is very good stuff…

I am still having the same issue with rc11? how can be fixed?
looking forward to hearing from you.

SLounis, do you have CAN enable and a standard gps or do you have a Zubax gps ?

I do have a standard GPS , the one comes with PH2.1

Check that BRD_CAN_ENABLE is set to 0

I want to use the UAVCAN as my ESCs are driven via CAN

Guess that it is the same problem for the CAN esc …

Hi . I am still having a problem with BAD Baro Health when my UAVCAN Enable! with the latest beta and latest Stable!

Any help of how to fix it ?

The same thing is happening to me SLounis. The gps and compass seem to work by assigning a node id but still have the Bad Baro Health.

Waiting for a fix…

Are you driving compass and GPS via UAVCAN? i have tested the drone. it seems to read baro data and still gives the error . i think its just an error on the display.

Hi SLounis,

Yes I’m driving GPS and Compass via UAVCAN. I haven’t checked if I’m getting baro data from it. Will do later this week

I am still on the same bad baro health prob. Anybody knows a way to disable zubax baro so we can at least use gps and compass?


Have you tried the latest beta, Copter-3.5.4-rc2?

not yet, will test it today and let you know.

Mission planner this morning told me there is a new 3.5.4, is it the latest stable? Can i try that?

thanks for your help.