BAD AHRS with Arduplane 3.8.4

Is any one else running into a BAD AHRS problem when they flash to arduplane 3.8.4? I have performed all the compass, accel, and radio calibration and I cant get BAD AHRS to go away. I did this on a pixhawk and a pixhawk 2. This is preventing me from even arming. I just have yellow lights flashing like it is failing pre-arm checks. Any help is greatly appreciated

I’ve moved this to the Plane-3.8 category because it was appearing on the front page of (it was set to “Blog”).

I know the AHRS in Rover reports “Bad AHRS” before it has a good GPS lock (issue here). I don’t think this behaviour is new though - as far as I know it’s been like this for quite a long time.

Anyway, if this is the issue, I also don’t think it’s helpful so I plan to change it at least for Rover at some point and it would hopefully find it’s way into Plane as well.

1 Like

Thank you for the reply. I manage to get bad AHRS to go away like you said get it out in the open.

However I am still getting the yellow flashing light of death:open_mouth: I re-calibrated everything and the HUD said all systems good. (See image below). I pushed the safety button it went solid red. Held my throttle stick down to the right nothing happened. The yellow light just kept flashing. Something strange happened though. When walking back into the building the led went green for about 3 seconds then it started flashing blue then yellow. Not sure what is going on now. Has anyone else been haveing this problem

I may have figured out what was wrong. I had to un-check some of the ARMING_CHECK boxes and I got the pixhawk to arm.

I’m having too the Bad Ahrs message even if the Gps signal is very good, 14 satellites 0,4 Hdop, I had to disable arming checks or the plane will not arm .
The EKF window in Mission Planner HUD shows everything disable .

In logs I do not see any error only the messages “EKF2 IMU0 is using Gps” and “EKF2 IMU1 is using Gps”

The EKF went away for me after calibration and taking the plane out to a large open field.