Background map not loading


My APM is on the way and to get familiar with the Mission Planer I downloaded to test it and found that the background map is not loaded.

You can see the image attached that I give all the permisions to the app and still no luck.

The app connects to internet as it can detect newer versions etc.

I’ve dowloaded previous verisons and same stuff.

I run W7 64b

[attachment=0]Imagen 3.png[/attachment]

Please help

Without a GPS input from the APM, the MP does not know where it is possibly.
TCIII ArduRover2 Developer

I dont think this is the problem since it could load the whole map and the error shown is a 404 one as if there was no conection. Also, downloaded the android apps for APM and they load the map instantly. I’ll try to install in other pc and see what happens.

Have you tried to zoom out? If you don’t have GPS input, MP centers on the equator in the middle of the ocean. Google doesn’t have detailed aerial imagery for that region, which might be the reason for the error you see.

Yes, you can see in this video. …

not present in the video but at maximun zoom I went until top right corner and no luck.

please try selecting a different map source. in the flight planner page.

Men, I feel so lame. I tried this at first but did not found anithing. finally found the tab, there are plenty of maps!! thank you so much!!