Back and Forth effect on Tilt axis

My quad is running the arducopter 4.05 with a Cube Orange on a Kore board with Hereflow, SF11C Lidar, Here+ and Here3 Gnss on HereLink. Tmotors 4014, 16 inch props on TMotors Alpha 40 esc. I did the autotune yesterday with good results both in Roll and Pitch axes. Today i tried it in auto Mode for a small mission to check it out. It started the mission good but after a while started doing this pitch up and down going back and forth effect all over the place. I took it over and manage to land safely. Here is the DF log.

Can someone check the log file please and advice?

1 Like

Most of the time Roll and DesiredRoll are close, but Pitch is always struggling

Eventually the oscillations are getting out of control:

Your motor outputs are not equal

It’s like you’ve got a weight/COG imbalance but also a bit of motor mount twist causing a physical yaw bias. This is not drastic nor the sole cause of the instability, but it’s definitely something to be fixed because it reduces the amount of control available for stability and desired movements.
You can even see in this graph where there’s a yaw change and continued motion, how the motor outputs change to match, but I think they should still be closer together.

Set all these first, then we’ll get into some other details:

The ATC_ANG P values are wrong for some unknown reason, and are a big cause of the oscillations. They get that far different usually by a mistake on the keyboard or mouse, or a serious weight imbalance during Autotune. Set them to be the same for now:
Something like this for a start:

For your size props, you’d normally use
but with the T-Motor Flame ESCs the consensus is to use these, they are essential really:

And for smoother RC input try:
or as high as 0.3

Perform all the changes above then do another test flight around in ALTHOLD with gentle stick inputs. Dont try missions and guided mode or anything fancy yet. Let’s see the .bin log file from that…
If everything seems fixed you could do another Autotune too.

These are a bit suspicious to me, but leave them as-is for now and we’ll see the what the next .bin log file is like.

Hey thanks xfacta i will do the changes and come back. The escs are Tmotors Alpha 40a and in their manual says they dont need any calibration so i have them set to use throttle endpoints in mission planner. Any thought on this matter?

That’s the purpose of these settings

xfacta thanks. I will put these settings.

@xfacta, i manage today and make a few flights after i reset pids to defaults as with the previous settings were still bouncing. In ALT hold mode is very smooth now even with default PIDs. In Loiter mode it does a small opposite direction movement (something like a brake) when i release the sticks with a small delay of maybe 1 second.

Maybe is something to do with Gps difference / delay? I have dual GPS one UAVCAN Here3 and One Here plus. I had them to “blend” and i tried also with “use best” option. No difference in behavior.

Most probably PID tuning.

Please follow the “PID tuning process instructions” step-by-step.

I Did it several times. Still have the same problem.

There are parameters for that.

Thanks @dkemxr i will try those.

That small brake after 1 second is the parameter LOIT_BRK_DELAY. Set it to say 0.2 or 0.1 so there’s not a noticeable delay in the brake/correction after a travel move

@Yasiinm thanks for the tip. I corrected the brake effect by changing values in LOIT_ parameters.