Awful Servo Jitter with 433MHz Telemetry

I have always had a slight buzz/jitter on the steering servo, but never anything too severe.

Since loading Rover 4.0 on my Pixhawk2.1 Black Cube the jitter is now so severe that it is shaking everything to pieces and the servo is so hot you cannot touch the motor, and a 26,000 MAh only lasts around 3 hours, which would normally last a full day.

I have had to resort to removing the 433 module physically from the controller after I have uploaded the flight plan / mission.


I’m a little surprised that the software on the flight controller is making the interference from the radio on the servo worse.

… or are you saying that the servo is moving a lot more than it use to even with the 433 telemetry radio disconnected?

Any chance you’ve got a dataflash log of before and after? Does reverting to 3.5.2 really resolve the issue?

I can think of two possible causes:

  • we’ve somehow reduced the filtering going into the steering controller
  • some other low level change that is affecting what we’re sending out to the servo

Randy, thank you for the reply.

Like I said, I have alway had a light buzz and a jitter once the safety switch is armed, but this was really bad, like I have never had before.

I’m also getting a bad logging message so I presume there is something wrong with my sd card.

I am going to try a foil shield on the 433 antenna and see if it helps.


@John_Easton, did you solve the problem?
I have 915mhz telemetry.
When I am in manual mode, all my servos are jitter and I can’t find a solution to the problem.
Is the side-by-side of the telemetry antenna and the receiving antennas a factor in this?


this is a boat and the 915mhz telemetry antenna and the receiving antennas are side by side.
when i start the boat all the servos vibrate by themselves, some search results say that telemetry is interfering, is that true?
how can i fix this?
@rmackay9 and @John_Easton, Do you have an idea or a solution suggestion?


It would probably be good to try disconnecting the telemetry radios to be sure they are the cause of the servo vibration. If it is then I think the only solution is to move the radios further from the servos or perhaps look for a different brand of servos or radios because it’s a radiated EMI issue… not software I’m afraid.

Hope that helps


Yes, I solved the problem. Thanks for your help!


You said you solved the problem?
I’m experiencing the same thing with the HC12 radio module at 433MHz.

Did you use other servos, or how did you solve it?