Servers by jDrones

Avoidance options not available

Im trying to setup avoidance on Pixhawk 2.4.8 with TF mini T01. Ive follow the instructions on connecting and setting up the lidar that the lidar came with. its on serial2. Im not getting any Health prompt’s so Im assuming the connections are right. Ive set the AVOID_ENABLE =2. When I look at the Avoidance options under basic tuning they are disabled. Is there something else I need to do to enable avoidance?
Ive you tubed and googled this and cant find a setup guild for setting up lidar on the rovers.

Update. I just fired everything up again and got BAD LIDAR Health. How can I determine what caused that error?

Good day, how do you supply your sensor?

Hi!
Can you please share your parameter file? It’ll be much easier to help you if you do that.
Meanwhile you should also have a look at how to set up range finder correctly and verify its working through your GCS:
https://ardupilot.org/copter/docs/common-rangefinder-setup.html#common-rangefinder-setup

I received an updated set of instructions from Benewake and the lidar is working now on serial 4/5. But for some reason its killed my telemetry link. Theres just no winning with this thing. Ill start troubleshooting that next.

Servers by jDrones