AUX channel failsafe settings

How can I set a passthrough on the AUX channel to default to a certain value while in failsafe?

I can’t seem to figure this out. Setting the radio failsafe doesn’t seem to have any effect as the Throttle failsafe kicks in first.

Any thoughts?


I have a liquid spray pump which MUST shut off in the event of signal loss. Seems very strange to me that this is not available (as far as i can tell…)

I attempted to bypass this issue by removing the Throttle based failsafe and setting the Frsky failsafe as follows:

CH9 (pump): Off
All other channels set to neutral.

I was hoping this would work, but when tested, the autopilot still enters failsafe and signals “No RC Receiver”. How does ardupilot know this? I can see the outputs from the RC on mission planner and they are correct but I still get this error.

Hi Simone,

Are you using the crop spraying feature?

If yes, then I think the simplest solution (if you’re using master Copter-3.6) is to add a line into the failsafe_radio_on_event to turn off the pump:;

That will handle the RC failsafe. To handle the battery or fence failsafes I think a change would be required in the switches.cpp where it processes the aux switch for the sprayer. == AUX_SWITCH_HIGH) && !any_failsafe_triggered());

I haven’t tested this but I think it should work.

We are not using the crop sprayer feature currently. The pump is simply manually controlled.

Thank you for the information. If you don’t mind, I would like to get in touch with Peter Barker. Could you send me his email?

Thanks again!