AutoTune problem: No axis goes beyond "Success 3/4"

First time using AutoTune on Copter for me today, and I didn’t have much success it seems. It ran for about 08:30 and from what I can tell, no axis was successfully completed in that period. “Success 3/4” was sometimes achieved, but never “4/4”, so no completion message in Yaapu. It seems like it went through all 3 axes but then started from the beginning.

The question is why, so I could try again tomorrow, hopefully with more luck. I inititated from LOITER as there was a certain breeze - maybe that breeze is the simple reason? Days with no wind at all (and no rain instead) are hard to come by around here unfortunately.

Here’s the log:

Thanks for any hints!

EDIT: Sorry, this should actually be in Copter 4.1.

Set ANGLE_MAX back to default. 30° is probably why you have all those “autotune reached limit” messages. Also you have MOT_SPIN_MIN lower MOT_SPIN_ARM. Fix that.

Thanks, I don’t remember ever changing ANGLE_MAX but according to my param history I did, back in April, from 45° to 30°. So I assume 45° is default.

I didn’t notice those “reached limit” messages in Yaapu or on OSD, and it seems I can’t view them in MP log analyzer either: “There is too much bad data - failing”. How do you make them (and other messages) show up?

AUTOTUNE_AGGR should remain as it is? I read in an older thread that relaxing it can help (speed things up) on copters with shorter flight times.

Thanks again!

The messages are there seen in Mission Planner. Turn off some other messaging, you will see them.

Don’t change aggression leave it at default. With small quads you can even increase it but leave it as is for now.

I’ve had very poor results trying to auto-tune with wind. You should initiate from Alt-hold, and I’ve found if the wind is enough that I have to make a lot of drift corrections then it’s probably too windy to auto-tune. And I live in a windy place too so I understand how much of a pain in the butt this can be.

Just for my own interest, what are you considering a small quad here?

There is a limit on what autotune will accept as level, if you have enough wind then the copter will never level.

Are you doing one axis at a time? That is the best way to get good results.

Thanks guys, now I have enough info to try again, really appreciated.

Not yet, for two main reasons. a) I hoped I could get away with doing it the quick & easy way, without using any GCS software and without blocking the flying spot (also used by other people) longer than necessary. b) It’s a bit difficult to see where the small 4" copter is pointing at a distance, needs more LEDs (as it was my 1st AutoTune, I was keeping a very safe distance, probably more than necessary).

If increasing ANGLE_MAX doesn’t help, separate axes will be the next step for sure.

5"-6" or less.


1 Like

I hear you about the wind. Maybe consider going the lidar/optical flow or some other non-gps navigation and doing it indoors?

You can do it indoors anyway if you have a large space. AKAIK it’s still best to switch from AltHold to Auto Tune (unless this has been fixed) so GPS isn’t used anyway.

Kind of a side question but does the channel 7/8 switch going into autotune work from loiter or just althold? edit going back and reading it, I see my question is answered in the docs

Unknown Pilot,just do one axes at a time at the field,roll today pitch tomorrow and yay the next day but better to get them right just my thoughts

If I remember correctly it only goes to 3/4 because it starts at 0, 1, 2 and then 3.

Either AltHold, Loiter or PosHold. But as I mentioned and as per the Wiki:

So switch from AltHold, it doesn’t matter if it’s from a Chan 5 flight mode or a Chanell option. Then when it completes, land and Disarm. Don’t switch to any other mode before disarming.

BTW-You can configure Auto Tune on any channel, not just 7/8. That was an old limitation.


Ok, so I waited one more day for less wind, this time it shouldn’t have been much of a factor. ANGLE_MAX also increased to 45. Yet the new result was about the same:

This time the last message on OSD (but not on Yaapu) was “AUTOTUNE: SUCCESS”. Then the copter was not doing anything anymore, just loitering. Yes, I initiated from LOITER again - but currently I think the main problem is not the quality of the tune result but the fact that nothing is saved.

Unfortunately I still haven’t been able to get all messages displayed as text that occured while AUTOTUNE was active, neither in MP nor APMPlanner. But on OSD or Yaapu there was no indication any PIDs were saved, although I landed and disarmed while AUTOTUNE was still active.

So I compared the param files and just like last time nothing had changed PID-wise.

Before knowing that, I flew a few rounds and noticed another oddity: The craft vibrated massively when entering LOITER. Even when hovering manually at the same throttle, there was no visible shaking.

I have another wind-less day coming up, so I could try again tomorrow if I knew what to change/try. Please excuse any lack of precision, I had a bad headache all day but absolutely wanted to make some progress with this copter.

Can anybody confirm this? Because once again the maximum I saw was “3/4”.

AUTOTUNE: SUCCESS means it worked, but nothing will be saved unless you disarm without changing mode.

1 Like

Damn, so I shouldn’t have switched from LOITER to ALTHOLD, but just landed, that’s it? I was under the impression keeping AUTOTUNE active was enough - but that probably is only true when it’s a flight mode?

In other news, I just watched some HD footage and the heavy “vibrations” that came up only in LOITER are definitely extreme yaw twitches. (But that was still without any tuning having been saved.)

I can confirm it. Just checked my last log for autotune and it never goes beyond 3/4. But like the boyz say. You have to land and disarm with out making any changes. Also if your using some form of ground station that speaks, you might not hear it say that the pids are saved. I have had a few AT’s done where the announcement isn’t done for what ever reason. However most of the time it does say so.

1 Like