Servers by jDrones

Autotune PID values not used in FBWA and other modes

Hello all,

On my Wing Wing z84 I use an APM 2.8 with Arduplane 3.4. I know this is archaic hardware and software. But I have it laying around so why not use it.

I have performed an extended autotune flight and I am pretty happy with the results. As far as I know the PID values are storen every ten seconds. I can confirm that every time I fly in autotune it behaves according to these new PID values. That’s great. It also seems that these PID values are persistent accross shutdowns of the APM. That’s also great.

The issue is that in any of the other assisted modes like FBWA, FBWB, Loiter, etc the old wrong PID values are used causing major oscillations and it will crash with these PID’s.

In Mission Planner I can indeed see the wrong PID’s at the Basic Tuning page.

My question is simple: Why are the PID’s acquired in autotune not used in any other flight mode? It looks like I am forced to do a manual tune. That is something I don’t want because autotune works quite nice.

Please help.

Regards

They are. Simply as that, there are no “per mode” PIDs

That is my understanding also. But when I change from autotune to FBWA (for example) the plane oscillates like crazy. And when I switch to autotune again the plane behaves like expected. Also in MP I see only the wrong (manually inputted) PID values from before the autotune.

did you read/follow http://ardupilot.org/plane/docs/automatic-tuning-with-autotune.html
at lease let it have plenty of data first ?

Sure. I read it many times. And I have flown in autotune for almost half an hour jerking the sticks. In autotune the plane flies very good now. It is responsive and handles wind good. Autotune works.

When I put the APM through a power cycle autotune still is good. But in FBWA the pitch oscilates like crazy and the PIDs in MP show the manual entries.

What I really don’t understand is that in autotune the plane flies progressively better. After a long flight in autotune is flies really well. But when I then switch back to FBWA the plane oscillates like crazy.

This I cannot understand,

Hi! Have you solved your issue?
If not, have you tried landing and disarming in Autotune mode? Because in Copter Autotune saves the PID results after land & disarm. Maybe that helps - i did Autotune only in Copter, not in Plane (until now)

Servers by jDrones