Autotune is not working with my quad.. please help!

Hi, I am pretty new in this community
and I am building my quad copter at the moment… But I have some trouble with autotune

I am currently using

  • pixhawk 2.4.8
  • APM:Copter V3.5.2 firmware
  • F330 frame
  • EMAX MT2204-2300KV BLDC motors
  • Airbot BumpBee 30A BLHeil ESCs

At the first flight, the drone flied… but it was really shaky.
It was not like random vibration but regular vibration about Roll and Pitch direction
And I found that this situation can happen when ‘I’ and ‘P’ gain are not properly fit to the body
So I tried Autotune… But It didn’t work… It didn’t change any PID parameters
If I connect with radio telemetry and monitor flight mode of my drone. the flight mode turns into Autotune mode but PID parameters doesn’t change

I followed all the instruction on Autotune Document specially ‘Common problem’ part… but it’s still not working… it’s still shaky

Do you have any idea or advice? It will be really helpful.
Thank you in advance.

‘regular vibration’ is usually when your PI values are too high - try lowering them a little bit before you start. Autotune does seem to require a vaguely decent starting point, although I’ve found recent versions to be more robust. Make sure you have one of the option channels set to autotune (ch7 or ch8), take off and get it into a stable hover in alt-hold or loiter. Make sure the throttle is exactly in the middle, then hit autotune switch. It should start twitching. When it’s stopped twitching for a while (if you have a GCS or voice telemetry it will tell you autotune success), then land and turn off the autotune switch. Disarming and/or turning off autotune should save the new PIDs for you.
Good luck!


Thank you so much for the advice! I will try in this way. Thanks!