Autotune is not working = Crash

Hello Guys,

I have a problem concerning my Qaud. It´s a Tarot Iron Man FY650.
I tried Autotune two times and crashed. Now I am a bit lost.

Here is my Log file.

I really hope that somebody can help me.
Thanks a lot.

Definitely update to latest stable firmware first - there’s important fixes for Cube Orange and others.

It seems like it couldnt handle the demands of Autotune, got into oscillations and when down.

Looks like you want to use DSHOT, which would be desirable. You’ll need to move the motor outputs from Main Out 1 (Servo1) to Aux Out 1 (Servo9) and so on…
You can use the Servo output screen in MissionPlanner.
Also change these related settings:


Use MissionPlanner motor test to verify the motors will start up reliably and smoothly at that MOT_SPIN_ARM value.
Hover thrust will need time to relearn in AltHold or Loiter.
Also join the telemetry wires from the ESCs all into one and connect to Telem4 RX pin and set:


Now for other settings related to stability:

INS_HNTCH_ENABLE,1  // set this then refresh params to see the rest

Alternatively if you get the ESC telemetry going just alter these ones from of their values listed above


And some PID adjustment that might help:


Something to physically fix is the motor alignment. In the log we can see a physical yaw bias caused by a twisted motor mount. Motors 1 and 2 (CCW) are working harder than 3 and 4 (CW) to counteract to yaw bias.

Rotate the props so the tips are all near other prop tips, or since this is a quad make the props into a square shape. Then look from the side, in the same plane the props would spin, and look for prop tips that dont align with neighboring tips.
Adjust the motor mounts so all the props are spinning on exactly the same plane.

Once the copter is ready for flight again, just take off in AltHold and hover for a while, maybe some gentle movements, and let’s see that .bin log file.

Shawn thanks for the reply.

I have the T-Motor f55 pro II ESC. This one is a 4 in ESC. The telemetry pin should be connected to which pin of the Cube Orange? I have no plan how to do it.

But I already made some hovering test and it went quite well. A little drifting but that was not to much and the copter is not jet tuned.
Can you please have a look at the log file.

Thanks a lot for helping.

You just need to connect that single telemetry wire from the 4in1 ESC to the Telem2 RX pin since that connector will be easiest to get to, and set the parameters I already mentioned, except change to SERIAL2


That’s looking quite good, Stabilise mode will drift because of any inconsistencies or wind.
Try AltHold and Loiter in the same flight.

You can safely set these for the next test flights.
I’m thinking you could do an Autotune and see how that goes. Set a transmitter switch to Autotune mode, or adjust your existing flight mode to do Autotune instead of something else.
Once you start Autoune you will need to reposition, possibly a lot, and once it stops twitching DO NOT switch out of Autotune mode, just “reposition” to land and disarm. Then you can switch out of Autotune mode and change to AltHold or Loiter and go test.

If you get that ESC telemetry hooked up, there’s a couple of minor settings to change to make use of it:


That wont affect how Autotune works - you have everything going OK now ready to try Autotune.

Thanks a lot for helping.

I didn`t get running the ESC telemetrie but I tried a Autotune this afternoon. It also didn´t worked.

But the copter stay very stable so i treid playing around a little bit in loiter.
My conclusion was that wenn i only fly In one direction like forward and backward. It stay very stable.

But when I tried to fly roll and ptich at the same time it started to oszillate and landed very very hard.

What can this cause. Roll and Pitch at the same time is a big trouble.

Mabey you can help me out. BIN. file is here.

Thank you I am very happy that you help me.