Autotune Failure

h210_4s_2x5045.param (12.9 KB)

Autotune aggr set to .1 and axis to pitch only. After autotune was complete I switched to new rates which immediately caused me to crash and break a frame. Uploaded params are rates prior to autotune. After autotune pitch P was .01 and stab p was .5.
Using 3.5 beta
Flight log

Anyone? It’s really disappointing that I can’t get a pixracer to fly as well as a cheap board running betaflight.

What size frame and how much power on tap.

Leaving the aggr set to .1 gives an unstable tune for all frames I have (too much power)

Have you tried it at .05?

210 size frame with 2200kv f60. I completed an autotune on earlier firmware with agressiveness at .1 on 2450kv motors so i feel its something different with my params or the firmware

You don’t say which firmware you’re using but on early 3.5 betas I found it did very bad autotunes on small frames (I’m running a 300 size frame with 2205/2000kv motors). Like you it would crash as soon as I tried to take off with the tuned params. One thing to check is the ATC_ACCEL_x_MAX values, it was setting these to very small values. Also make sure you’re setting AUTOTUNE_MIN_D to a very small value, at least 0.001 (earlier firmwares had this set higher). Also try with less aggressive setting (0.5) first to see if that works.
I tried the latest beta recently on the same frame and it produced flyable tune.

Thanks for the reply. I just configured the latest beta and so far have had success autotuning yaw. Pitch still wants to set the rat_p at .01 for some reason. I’m going to try roll next.
Min D is currently set to .0008 as that was about what I was using for roll when I was tuning manually. I just started trying to use autotune as I could not get attitude to hold in agressive turns. I’m hoping autotune starts me with a better base to continue manual tuning.

I’ve found an issue. When The autotune is complete and I switch to the new rates. It flies beautifully. After I land and disarm. If I plug the battery back in and fly immediately after, its on the extremely low rates I’ve been seeing in mission planner. It always sets the rate p to .01

For some reason its not saving the new rates after autotune is complete. It saves them as .01 after I disarm.