Autotune - failure in calm winds

I’ve been challenged getting my new Hexsoon EDU-450 V2 tuned with autotune.

I built the “V1” of this copter over a year ago - it had no trouble with autotune. It would complete all 3 axis within the 20 minute flight time of the 5200mah battery.

So far, I’ve been unable to complete autotune on even one axis on the V2 version of this copter.

Using values from the V1, the Mission Planner stored parameters for the EDU-450, the firmware defaults and some manual adjustments, I was able to come up with PIDs that allow for stable flight.

The copter behaves pretty well with this set of parameters - but as the data show it’s not yet tuned well:

Late yesterday afternoon, in perfectly calm winds, I made another autotune attempt. First I started from LOITER - but after a few minutes of the copter sitting perfectly stationary in flight, it produced no twitches.

I landed, switched to Altitude Hold, took off, and tried auto tune again. This time I got some twitches - but there were so many “Autotune - failure to level” messages, there weren’t enough twitches to complete the one axis I had set for Autotune to perform. Here’s the log from that flight:

My hope was to begin learning how to tune my copters to a finer degree than autotune. But as I can’t seem to even get this copter tuned well enough for autotune to complete, I’m facing quite a challenge.

I’ve read the substantial past threads on this topic such as this one:

But I’m still at a loss.

Is it possible that when autotune was changed to include the message “Autotune - failure to level” that something else changed that made autotune more difficult to use?

Regardless, I’d greatly appreciate some guidance on how to make progress on my tuning efforts.

Thank you.

Hi Joseph, The message says: AutoTune: failing to level, please tune manually.
You say you performed Autotune with success a year ago. Since you now use AC 4.2.3 I would suspect some parameters might miss but I am no expert here. Did you do initial setup? Dave teached me some stuff to do before running AutoTune: The Dynamic Notch Filter should be configured before you run Auto Tune so enabling INS_LOG_BAT_MASK is good to collect data for that. Then make a short Hover flight and review that log to configure the filter. Then make another flight setting the logging option to post filter and review that log to see if the filter is doing its job. Then think about running Auto Tune.
Regards Espen

Thanks Espen -

I’ve followed the ArduPilot doc’s process on tuning. It’s sequence is to perform auto-tune before setting the notch filter. So I’ve not yet performed that step.

I’ve now heard from several sources about doing the notch filter first - so I’m thinking I’ll try that and see if it succeeds with auto-tune.

Absolutely you need to do that. Otherwise you will just have to Auto Tune again after configuring the Notch filter. Auto Tune has been around a very long time (~9yrs) and the Dynamic Notch Filter is a relatively new addition (~4yrs) so the sequence in the Wiki may not be clear. Actually the sequence in the Wiki for the Notch filter is not that clear.

1 Like

Thanks - and indeed - the Notch filter instructions were poor the last time I did that step. I was hoping they’d been fixed by now…