Autotune doesn't start

Hi there, I continue some test flight with my new slow fly quadrotor.

I’m facing with a problem never encountered. ( Autotune on my F450 works great)

I try to perform an Autotune to tune this quadcopter perfectly, but It doesn’t work, when I invoke Autotune inflight with my CH7, nothing happens.

I do not understand why and I would like to solve this problem,

Does anyone can explain me the reason or help me to find it ?

Here are my logs : … authuser=0 … authuser=0

Thanks !!!

Does anyone can give me an beginning of solution or possible cause??

Have you gone into mission planner and setup switch/channel 7 to autotune?

Sure I have, take a look to my attached img.
in add, got an error in my log when I switch Autotune mod :

27/04/2015 10:54:47 - 043392: Mode Changed to 616 27/04/2015 10:54:47 - 043392: Mode Initialised at 50.033057 5.5083942 Alt: 7.95 Spd:0.29 27/04/2015 10:55:10 - 048701: AUTOTUNE ERROR: Bad Gains (failed to determine proper gains). 27/04/2015 10:55:44 - 056348: AUTOTUNE ERROR: Bad Gains (failed to determine proper gains). 27/04/2015 10:55:47 - 056976: AUTOTUNE_OFF

You can download the full log here : Google drive

Thanks to help me to understand what’s wrong.

I have the exact same issue with version 3.2.1. Autotune engages, but nothing happens - then it switches back off.

Maybe did you can provide your log to compare-it ?

Wich copter did you use ?

Please give me more detail.


My copter is a Tarot 650 frame running on 3S with Rctimer motors and 10x5.5 props.

I have successfully autotuned it with an earlier firmware. Which logfiles is of intersest - .log, .bin or .tlog?


mmm ok so it looks like this is a firmware issue maybe ?

About the log file .log or .bin are ok as well


Two more flight today ans still can’t perform Autotune , even after make some PID’s change.

Still any help here ?

ch7 doesn’t change for log ending 10-06-35

are you sure your radio is set up properly?

Mmmm you’re right there is something wrong in this way, I will check my radio calibration an configuration .

I will post my feedback after some investigation .

Hello here,

So as promised here is my feedback,

as advised by RabbitStu, I’ve checked the CH7 parameter, ans it was correctly set in MP so I’ve do a nex radio calibration and this solved my problem,
I suspect have forgotten to switch on the ch7 in my first calibration

Anyway this topic is definetly solved but no news from pkvaloy ?