AutoTune doesn't restart after centering vehicle

I tried autotune for the first time this morning on my Pixhawked S1000 and while it started just fine, it drifted away from my test area after ~5 rolls. So I re-centered it manually with the roll/pitch stick, then let go of the sticks, and it just hovered there, no more twitching.

I was under the impression that as soon as you let go of the controls that the auto tune will continue where it left off.

What should I be checking for? Is there a minimum altitude limit?

Hi Mike,

I recently converted a DJI S800 over to the Pixhawk and I completed the autotune process for a two different arm/motor/propeller combinations a couple weeks ago. I often had to re-center and found that it wouldn’t resume unless my throttle was very close to where I had initiated the autotune.

Just a few questions about your setup. Have you set the autotune to CH7 or to an additional flight mode? Are you transitioning to the autotune from AltHold? How is manual control of the S1000 in Stabilize/AltHold?

In addition, if you haven’t already, I’d suggest changing the FILT value for Rate ROLL and Rate PITCH from 20.000 to 10.000.

I’m happy to answer any other additional questions, especially while it’s all still fresh in my mind.


Hi Adam!

Thanks for the reply. Would it restart when you moved the throttle back to where it was? I don’t recall moving the throttle very much. It was in AltHold mode which puts a dead zone around mid throttle. I’ll try again without moving the throttle, but it doesn’t hold altitude very well.

I set it up so CH7 initiates autotune after the vehicle is in AltHold mode set by CH5.

I have not changed the FILT value, what is that? What I have done is turn down the roll/pitch sensitivity and roll/pitch feel. They are one tick from the lowest value. I also turned down the climb sensitivity to a couple ticks from the left. It was way too squirrely with the default values. Even now it’s a bit much to handle, I was hoping the autotune would help make it more manageable.

The yaw is also very sluggish.

Hi Mike,

I found that while conducting the AutoTune, my aircraft would often drift and I’d have to adjust the altitude. When I did so I noticed that it wouldn’t resume until my throttle was pretty much exactly where it was initially.

Regarding the FILT parameter, the AutoTune article suggests that the Rate Roll and Pitch filters be changed to 10 Hz when using propellers larger than 13 inches (33 cm). This change yielded a considerable improvement in the stability of my S800 while in Stabilize and AltHold. You can make this change either by a) going to CONFIG/TUNING > Extended Tuning or b) going to CONFIG/TUNING > Full Parameter List and changing the ATC_RAT_RLL_FILT and ATC_RAT_PIT_FILT parameters to 10.

The important thing to remember is that the AutoTune requires that the aircraft be relatively stable while in AltHold mode. If it’s currently unstable in this mode, hopefully the changes to the roll and pitch filters will help. Please let me know how you make out!



Thanks, I missed that note in the article. I will make that change before trying autotune again along with keeping a closer eye on my throttle.

Any other tips? The S1000 is a bit heavier than the S800. I am flying it at nearly it’s MTOW ~11kg.

Hi Mike,

Are you attempting to AutoTune with a gimbal and/or payload attached? I conducted my AutoTunes only after having removed my gimbal (Setup before flying point #3 in the article) and confirming I could achieve stable flight in AltHold mode while flying barebones. I’d suggest doing the same, especially if the gimbal could be a source of wobble.

As for other suggestions, I’d make sure to record all of your PID values on the Extended Tuning page before making any changes. I’d also suggest decreasing the aggressiveness of the AutoTune by changing AUTOTUNE_AGGR to 0.075 (medium). Also, I found tuning a single axis at a time to be much easier.

Once fully tuned, I reattached my gimbal and payload. Using S800 EVO arms and motors, which I believe are the same 4114 PROs on the S1000, I have a TOW of about 6.6 to 7.1 kg (depending on sensor). I’ve conducted a few hours of flights since then and everything has worked well so far, knock on wood!


Hi Adam,

I am flying it with securely-attached (no wobble) dead weight that simulates the weight of the payload. To me, it makes more sense to autotune at the typical flight weight rather than a much lighter configuration that you normally wouldn’t fly at. I’ve also found that it is easier to fly when heavier, more stable, not overly responsive (makes sense).

Thanks again for your help. Hoping to try again early in the morning when the wind is calm.

I’ve found that for me at least if my throttle stick isn’t at exactly 50 % or thrott mid it won’t start and it won’t continue after repositioning until I put it back.

Does it this way on all of mine. Since 3.3.3 I think.

Tried again this morning and didn’t touch the throttle stick at all. I just made sure I had enough altitude (~20 ft) to accommodate drift in the barometer. This seemed to do the trick!

The issue I ran into, however, is how long it took! I set it to tune roll and pitch only. It took about 8 minutes to finish roll and I only got about halfway through pitch before I had to put her down due to low battery. So unfortunately no PIDs were saved. I did spend a lot of time re-centering it because it was drifting away badly and there were trees nearby. I’ll try again doing 1 axis at a time.

Can I copy my roll PID settings to the pitch axis? The vehicle is symmetrical…

Should I be use voltage scaling of the PIDS? If so, what voltages should I use? Mission Planner and the AutoTune Tutorial suggest different things. I’m thinking 4.2 V/cell for max and 3.0 V/cell for min. Fully charged is 4.2 V/cell, but as soon as it’s airborne it drops down to around 3.8 V/cell.

Hey Mike,

Glad to hear about the throttle position working out for you.

I also encountered some long AutoTune times, even while indoors. Tuning one axis at a time definitely did the trick. It also has the benefit of allowing your brain to focus on movement along a single plane.

Regarding the copying of PID values over to another axis, I’m not too sure on this one. While your S1000 is symmetrical, there could be imbalances in weight between your payload and batteries. I’ll post my pre- and post-PID settings below to illustrate how different the Pitch and Roll axes are. Please note however that I didn’t have a dummy payload weight attached.



Not immensely different, but I’d suggest completing an AutoTune for each axis just to be sure.

I also noticed the AutoTune article mentioned voltage scaling of the PIDs but I haven’t enabled it yet. I’ll be soon operating my S800 in the Canadian Arctic, so the voltages are likely going to be influenced by the cold temperatures. For my 6S batteries, I’ve found through testing that the voltage failsafe should engage at approximately 20.75V under load (3.45V/cell), which recovers to 3.7V when not under load. That’s about as low as I’d want to take it. Every battery is different of course, but 3.0V/cell under load might be too low.


Hi Adam,

I successfully tuned roll today and copied these parameters to pitch. It flies very nicely like it’s “on rails”. I have not tuned yaw yet, that definitely needs some work. I understand the reasons not to copy them, the moment of inertia about the CG are likely slightly different, but it’s close enough for now.

The values autotune gave me seem quite high, but maybe that’s because it’s such a large and heavy copter. When copying the PID parameters from Roll to Pitch, the Rate Pitch P was above the limits of 0.3 according to Mission Planner, but I used it anyways.

Now my next question is, the autotuning seems to have minimized the Climb Sensitivity and maximized the Roll/Pitch Sensitivity sliders on the Basic Tuning page. The Roll/Pitch Feel did not seem to change at all. Can I adjust these sliders in the future to tweak it, or does that effectively nullify my autotune?

After AutoTune:

Roll response during AutoTune:

Pitch/Roll response after AutoTune:

Just got done autotuning yaw and the numbers are a bit startling, as in they are FAR different than the default values. Yaw feels better, but it has a tendency to keep yawing after I let go of the stick. From my memory, it can continue yawing up to another 90 degrees after a hard yaw one way or the other.

After autotuning yaw:

During autotune of yaw:

Hi Mike,

Great to hear you were able to AutoTune your roll. It’s a wonderful feeling when the aircraft finally responds to your controls as you would expect it to.

Your PID values are certainly much higher than mine, but this could definitely be due to the fact you are operating near the MTOW of the airframe. I previously came across another Pixhawk/S1000 build featured on the forums that had similar values, so at least you’re in good company:

As for the Roll/Pitch Sensitivity, I’m afraid I don’t have much experience adjusting this value. Based on the fact the numbers appear to line up between your Rate Roll/Pitch values, I would expect that you’d be directly adjusting the tuned values. This is not necessarily a bad thing however, as often times the PIDs set by the AutoTune should be fine-tuned. Regarding the Yaw, by the sounds of it you may want to try decreasing the values it until it begins to behave more reliably. Yaw is the axis that often times requires the least amount of tuning, so for the AutoTune to increase it by more than 700% seems a little suspect to me.

If you have the chance, I’d love to see a photo of your setup!