Servers by jDrones

Autotune can't seem to remove oscillations

Hello,

I have thought more about what might be causing the issue as stated below. I think it might be because I moved the cog rearward, the elevator becomes more effective in pitch. Now the autopilot is over controlling the elevator inputs and therefore overshooting each time and causing the oscillations in pitch. I still don’t understand why auto tune did not fix the problem. However maybe I can manually fix the issue if anyone has any ideas…

I have moved my COG aftward and have since noticed that my aircraft oscillates in pitch quite drastically as soon as the speed reaches about 10-11m/s. (I did not fly in manual today) I would have thought that my Pixhawk cube 2.1 and autotune would have fixed the issue. However, it didn’t so I tried reducing the PTCH2SRV_D from 0.04782997 to 0.00782997 and this did not seem to change anything. If somebody is able to point anything out to help, I would really appreciate it. Here is my .bin from today’s flight.

Justin

Some other issues perhaps related or not:
I get compass error variance at high power settings.
At times the track line does not seem to be accurate.
The wind vector in the top left seems to overestimate the wind velocity.

Have you flown this aircraft in manual mode?
That should indicate just how flyable it is.

If you cant control it in manual the poor FC is not going to have much of a chance.

Thanks Mike. To be honest I was kicking myself for not switching it over during the flight. I was already packed up when it occurred to me. Unfortunately I can’t fly until Friday now so until then I am just trying to decide what to do.

Definitely check that you CG is in front of you neutral point. Usually the CG is right at or just in front of the quarter chord.

Servers by jDrones