Autotune and Compassmot


Just got my Pixhawk, removed my KK2 board and plugged in the Pixhawk. My quad is flying OK with the defaut PID numbers but could use a bit of a tune. I have tried to map channel 8 to Autotune but when I get the quad in the air, switched to alt mode, and hit channel 8 to start the autotune, it doesn’t do anything. (I have verified channel 8 works by first assigning it to RTL which worked fine). Has Autotune been taken out of the current firmware (that MP downloaded during the initial setup)?

Also, I heard that Compassmot isn’t working for pixhawk right now…is this true? Something about nan values being written to the parameters making the artificial horizon move in circles even when the vehicle is sitting on the ground…

Why can’t I get autotune to start its thing…and is it ok to use Compassmot with the current release?

Thanks for your help!

[color=#00BF00]Please check the instructions on How to use this forum and add the missing information.[/color]

I’m running the 3DR Pixhawk, 3DR GPS, 3DR Telemetry 915 Ghz radios, loaded with Arducopter 3.1.2 Quad and Mission Planner 1.2.99.

Does autotune and compassmot work with this firmware?


Same question/issue as Marco. I just updated my firmware and tried a compassmot with no luck. Can anyone shed some light on how to do a work around here or when a new code will be released with a working compassmot (Looks like git hub issue is closed).

Autotune does not start until the sticks are considered centered.

If you haven’t done the radio calibration, or if you’ve leveled the copter with the radio trims rather than by using the accel calibration, auto trim or save trim features, then autotune will not start.

The compassmot issue is fixed in master, hence the closed issue. You could perhaps load the code from master, perform the compassmot procedure, then go back to 3.1.3.

3.1.3? I thought the latest release was 3.1.2? When you mention “loading the code from master”, I thought the latest release was always delivered by MP in the Install Firmware area? (Which for me states that Arducopter Quad is at 3.1.2…)

Please let me know if I should be getting the latest released firmware from somewhere other than MP. Thanks!

Further, Thanks for your info on diagnosing why auto tune isn’t starting for me - I don’t think I have any radio trim going on and I’m pretty sure I had my sticks in neutral in alt-hold mode when attempting to start the procedure. I have done both the radio calibration and the accel calibration a few times. I didn’t realize that there was an auto trim function. How is the auto trim function executed? If all of these check out - Is there anything else I can check to see why autotune doesn’t start?

Thanks again,

Ok - so I checked my radio trim settings and indeed, I had some trim on my radio. I zeroed them out on the radio and then performed the auto trim function (arm for 20 seconds - got flashing red and blue on the pixhawk) and flew in stablize for a bit, landed, and disarmed. Took it up again, and it is nicely trimmed now.

I then tried going into alt-hold, hit autotune, and bingo it started doing its dance. Landed and disarmed. PIDs got saved. I’ve never manually tuned anything, so I don’t know what these gain settings do. Changes are as follows:

Stabilized Roll - from 4.5 to 10.5
Stabilized Pitch - from 4.5 to 10.5
Stabilized Yaw - Unchanged at 4.5
Loiter PID - Unchanged at 1.0
Rate Roll
P - from .15 to .11
I - from .10 to .11
D - from .004 to .0065
Rate Pitch
P - unchanged at .15
I - from .10 to .15
D - from .004 to .008
Rate Yaw
P - unchanged at .2
I - unchanged at .2
D - unchanged at .00

Do these numbers make sense? Quad seems to fly ok - can’t really tell the difference to be honest.

Anyway, I wanted to complete my tuning and took jschall’s advice to try to get compassmot working…so I rebuilt the firmware from Master - loaded the new firmware - went into terminal, (firmware reported is 3.1.2 dev) but when I enter the setup command, compassmot is not an available command. Did I do something wrong in compiling the firmware from the master github repository?

Thanks for all you help…