Servers by jDrones

Autotakeoff don't control pitch

Hi ,
I have a crash in takeoff due to malfunction of elevator . Autopilot don’t control the pitch in takeoff and cause the stall . please see the log (pid.p ,elevator , pitch)

Hi there

If you take off manually, does the aircraft fly nicely in normal auto mode (waypoints) ?

I’ve already had automatic takeoff and cruise with this plane. But also in them, the angle of the pitch was increased from the maximum angle set.

I have been studying your log. I think the AP did its best to control the plane that may have had a problem. You gave very little information in you description of events. Pitch control problems. Looks to me like you hand launched a big plane and the battery shifted aft making the plane tail heavy and not flyable. Or perhaps the battery did not shift and your plane has an existing problem and you were just lucky on the previous flights. If this airplane has not been flown manually and proven airworthy, then you can not blame the autopilot.

Hi,
I’ve been experiencing the very same issue with three different pixhawk cubes (black). Approximately 3 days ago i’ve succesfully completed 3 full autonomous flights including auto take off and auto landing. No idea why but now my planes elevator do not respond in auto mode and everything else seems working fine. Btw. my elevator is working correctly on stabilize mode.
I’ve realized the issue on the runway while plane did not take off on the auto mode.
Then I tried to cancel auto takeoff and changed into the auto mode on the air still same problem occured plane started to dive but as far as i saw ailerons and rudder was working fine.
After that i’ve tried to cross check servos, power supply, elevator pin out on pixhawk, radio, and even pixhawk itself by changing with a spare / different one of them. Common conclusion: while i checked from mission planner i saw that in auto mode pixhawk does not send more than 5 pwm to elevator

I’ve tried on a three wheel (tractor type) trainer plane and also on a tail dragger.
I’m using params,
TKOFF_THR_SLEW = %127
TKOFF_THR_MAX = %100
TECS_PITCH_MAX = 15
TECS_CLMB_MAX = 5
TKOFF_TDARG_ELEV = 0
TKOFF_TDRAG_SPD1 = 0
TKOFF_PLIM_SEC = 2

p.s: i’m kinda new into these issues i can supply any lacking information which is required

@sophophobia can you provide a log?

Uploading: 5 23-Aug-19 17-59-44.bin.log…
Here is my last test but this one is a bit different i’ve opened the stick mixing and gave pitch from radio. Plus at the end plane crashes into a tree because of a strong side wind.

Update on the issue, changing pid’s have seemingly solved the elevator problem.
However I’ve never changed a value of pid’s or never set autotune. Are there anything that could affect/change pid values?

imho it‘d really help a lot to add logs, without that information it‘s mainly guessing.

arduplane defaults are aiming at a good first flight experience with sufficient safety margin on a wide range of airframes. imho they’re a pretty good place to start from, there might room for improvement for each indivdual airframe though. that being said, i myself have never seen the attitude controller completely fail on default settings, that’s why i’d suggest to double check if it’s really been the pitch P that solved your issue. there’s a lot of things besides the PIDs that determine your airframes capability to climb out at the given angle / speed.

When you launch you always have the wind coming to the nose of the plane correct? A local guy kept crashing his stratosurfer and was convinced it was some sort of problem with the flight controller. He was always throwing it with the wind at the tail, so basically no lift generated by the wing and the nose dives into the ground. Maybe some of your early flights had a good head wind and the crash flight didn’t? It can also be the plane needs a good headwind and a hard throw to get control authority, so on a less windy day it’s harder to launch. Flight controllers can’t override the physics that cause planes to fly.

2019-09-03 09-55-31.log.param (14.8 KB)

Could you please have a look at the last flights log files attached. We have made two full autotune flights, right after the second land took off with auto mode. Despite the mildly satisfying take off (pitch was not enough) past all waypoints with around 20 meters radius. (WP radius was set 8). Also while descending for landing again misplaced itself and had to take over the control to land manually.

that’s a parameter file, not a log though. i couldn’t spot anything really striking in there, just some observations:
your pitch P is 1.18, that’s quite close to the default of 1. we don’t actually know what your pitch P was set to before, but if you came from default, imho it’s rather unlikely that slight increase substantially changed your plane’s pitch authority.
you’ve more than doubled your LIM_PITCH_MAX to 47° while, judging from what you say, your plane does not even reach TECS_PITCH_MAX’s default of 15°.
your main control channels are calibrated to center trims near 1500, only your elevator channel’s input is center-trimmed to 1604ms, the elevator servo output however is inverted and centered at 1400ms, with the travel limits extended to 1000-2000ms.

imho the limited information provided allows for guessing only. my educated guess is you’re trying to fight mechanical and / or aerodynamic pitch authority issues using your FC’s parametrization.

it would really help to know more about your airframe, like how it performs in non-automated flightmodes, with special regard to climb performance and pitch authority, as well as to provide some actual flight logs.

generally speaking, while ardupilot defaults usually provide more than sufficient autonomous flight performance on a wide range of airframes, if a lack of pitch authority or climb performance does not allow a reliable start in FBWA or AUTO on full throttle, likely there’s basic physical adjustments to your airframe required.

Although this is an old thread, I thought my experience might be helpful. I have a StratoSurfer (converted to a twin) and I initially had significant difficulty in getting launches to succeed.

The PIDs that I eventually arrived at with AUTOTUNE were fairly normal for roll. But for pitch, I ended up with a P value of 2.12.

I’ve also determined that the elevator ceases to do much at speeds below about 10 or 11 m/s (~22 MPH) This is very noticeable when attempting to flare for landing. At 8 m/s, the plane flies fine, but up-elevator does nothing useful. At 11 m/s, you get a nice flare. This means that getting pitch up during takeoffs is bit difficult.

I can suggest a couple of things that can help during takeoff.

  1. Flaps make a big difference

  2. Since I have my motors up front, I jiggle the plane in AUTO mode and get them to ramp to full thrust before throwing the plane. This eliminates any delays in adding airspeed as quickly as possible. Probably not a good idea with a pusher setup.

  3. Since the fuselage is too large and heavy for me to throw with one hand, I use both of them. One is under the back half of the wings. The other is at the very tip of the tail. When the plane is moving forward and is just about gone, the hand on the tail switches from pushing forward to pushing forward and a bit down. My hand on the tail thus pitches the tail of the plane down (which pitches the nose up). By the time the flight controller starts to correct for the hand-induced upward pitch, the flight controller’s demanded pitch is rising. The following plot shows IMU AccX in green (the first peak starts the motors, the second green peak is the actual throw). The red line is altitude. Yellow is actual pitch and blue is demanded pitch. You can see the throw releases the plane at 20 degrees while demanded pitch is only 7. The actual pitch is quickly reduced to about 5 degrees but then rapidly climbs back since 14 degrees is the demand from the flight controller

ArduPlane wants to see forward speed prior to calling for upward pitch. Between the delay in spooling up the motors for effective thrust, waiting for speed before calling for pitch, and waiting for the elevator to pitch the plane, it can easily lose enough altitude to intersect the ground.

did you notice any difficulty holding wings level in AUTO mode?

No. It does well in auto mode for roll. Pitch has a bit less authority and was more of an issue for me during launches until I learned to spool the motors before the release. Neither is an issue when flying IMHO.

Servers by jDrones