Autopilot problems


I’m building an autonomous hydrographic survey boat for my fyp. I need to demonstrate it next week and as I don’t have access to water I’m building a prototype on a rover for demonstrative purposes. I went for my first test at the weekend and everything is working fine apart from auto.

I don’t have a controller with a three way switch so I have to set manual/auto from mission planner. When I set auto all the rover does is turn left and drive around in circles at a fairly high speed. I’m assuming this is a compass calibration issue. I have been having problems calibrating the compass with mission planner. There’s a few white dots at the end that I just can not get. I’m taking well over 1000 samples but it doesn’t seem to be working correctly. First I noticed it was facing south when I was facing north and also the scene on mission planner seems to rotating invertly when I rotate the rover. So I calibrated it again. It’s now pointing in the correct direction but still bad compass health and all she wants to do is go around in circles

I was using a neo6 gps and compass but I just bought an n8m but I still seem to be having problems. When I rotate the gui doesnt seem to be regestering circles jusst random lines and dots in blue green and red. When i watch youtube videos it not like what im seeing in planner

I have two questions.
First do you think my compass calibration is my problem

My second question is there any way for me to set the auto/manual from my controller? I don’t have a lot of experience with RC tech so I don’t really understand my controller. It’s called a titan T6 or I I think a rebranded Flysky ct6b. it has two toggle switches on and off on Chanel 5 and 6 can I use one of these for auto/manual?

The mad circling issue could be caused by a number of problem and it’s very possible that it has nothing to do with the compass.

For the compass calibration it’s best to use the onboard compass calibration instead of the “live” calibration.

for the mad circling, first make sure the vehicle operates correctly in MANUAL mode. Next try Acro, next Steering and finally Auto or RTL.

Uploading a dataflash log here so we can check it will make it easier for me to help.

thanks for using ArduPilot and reporting back!

Hi thanks very much for getting back to me.

I have a bit of an update. I’ve installed the neo n8m gps and compass and while at first I seen no change I tried to calibrate without the jumper in for the external compass.

I have managed to complete a correct calibration but the drone on my mission planner screen seems to be still pointing in the wrong direction. It’s heading is west when it should be north. It’s possible that i still have not calibrated correctly and it was pointing West when I started the calibration and it thinks it is pointing north.

I haven’t yet had a chance to check auto mode as it’s been raining ever since I got the new compass but I hope to this evening or tomorrow.

Can you suggest some things I could try during testing? Also how might I go about accessing the log file to upload here?

Manual mode seems to be working fine… the controls are inverted but apart form that everything seems ok… it’s pulling a little to the left while traveling in a straight line but I’m thinking that may be a mechanical issue on the river due to incorrect suspension setup or as a result of a collision during ‘’mad circling’…

Thanks again for your replay. I have to note although I’m having a few problems this is an incredible piece of kit. Thanks for all the work

If the control is inverted, then the expected outcome would be the Auto would drive it in circles…because it’s trying to turn right and no matter how hard it tries, it only goes left. How you fix that will have to be answered by someone else. But I feel certain this may be the main issue.

Oh right great thanks for your response. I didn’t think too much about it. Assumed it was a controller setup issues and was coming from the input but now that you say that when I tried to reverse the input during radio calibration it had no effect on the output.

Thanks, if anybody could ahead some light on this it would be great.


On the RC calibration wiki page it has this good advice about getting the RC input into the flight controller correctly setup:

The green bars should move in the same direction as the transmitter sticks (except for Pitch where the bars move opposite to stick movements - low values are forward, high values are back). If the green bars move in the wrong direction, reverse them using your RC transmitter’s channel-reverse function (see your RC gear’s manual for guidance).

Re the heading being off by 90 degrees. You’ve made sure the GPS/compass module is pointing forward? normally it has an arrow on the case which indicates how it should be oriented on the vehicle (the arrow should point forward). Not all GPS/compass modules have this but many do.

Txs for using ArduPilot and getting involved here on the forums!

My compass didnt have anything to identify orientation but I think I have found what way is forward. Ive unplugged the external now and Im running from the internal. It seems to be working better than the external in reguards to orientation but I still cant run a full auto mission it just seems to want to circle around the first waypoint.

Is this possiblely because im in loiter? I have only two chanels on my controler so ive no way to select auto mode so I am doing so from mission planner. Should I select mission start, Then auto or possibly auto then mission start? After It circles it seems to be unresponsive to everything but manual

First step FlRST .Manual. . if you don’t mind, post a Photo. A picture will be better than a thousand words…

Hi thanks for your reply,

What would you like me to post a picture of? I’d be more than happy to as I need the help. I kind of need to run an auto mission by tomorrow for a demonstration in a university.

I’m going to do a radio calibration now I’ll post the results.

Yeah after checking manual mode everything seems fine. its strange every time I tun it on either with internal or external compass im out my 90 deg to the right. It will look in the correct orientation after a calibration but this seems to be the case every time I reboot. At the moment my compass setup is internal with the external disconnected and the jumper is on the compass pins.

here is a picture of my main screen

and here is my compass page

Here is my rover for fun


I just got it to work, Thanks for all your help

1 Like

Great. Looks like a really old version of ArduPilot is installed on the board (see ArduRover-2.51-beta at the top of the mission planner?). Rover-3.2 is the latest stable version and 3.3 has just started beta testing.

Is it a Pixhawk on the rover or perhaps an old APM2.x board? If it’s an APM board then it would be a good idea to upgrade to one of the more modern boards.

By the way, there is advice on the compass wiki to determine the orientation. With the MP you can also graph the mx,my,mz and mx2, my2, mz2 value to compare the raw sensor output from the internal and external compasses.