Autopilot mounted at 90deg to front/back line

Hi there,

I’m relatively new to ArduPilot but super keen too understand more. I’m building an autonomous boat and using an Cube Orange running ArduRover 4.12 as the auto pilot. Originally I had the Cube Orange mounted facing forward as recommended, and once I had calibrated accelerometers and compasses it looked good in Mission Planner and tracked movement of the boat as I rotated it in the horizontal and vertical planes.

Recently I remounted the Cube Orange so that its actually facing left, not straight ahead, as I had some physical constraints. Since doing so I have not been able to successfully configure it in Mission Planner (latest version, got updates today) to say it is mounted 90deg out of line. So whilst testing today I have my electronics pack facing North (which means Cube orange is facing left/west), and as expected the autopilot thinks its facing West (i.e. the direction the Cube Orange is physically facing).

I’d imagine its just a matter of telling ArduRover that the autopilot is physically mounted rotated 90deg to the left and it would then take that into account in all calcs (compass, accelerometer etc).

Is this possible?


change AHRS_ORIENTATION to set your flight controller orientation, but it rotates everything so you have to turn your compass to match the flight controller or add yaw 270 to the compass.

thanks @geofrancis I’ll give that a shot. I had tried setting that AHRS_ORIENTATION parameter, but left my other compass, the one in the Pixhawk4 GPS unit facing straight ahead, so maybe that was the issue. I will try again.
Also you mention adding yaw 270 to the compass, I tried that in the compass calibration screen and was unable to click there drop down box to set that. Not sure why, but I could not make changes there for some reason?
And finally, do you need to reset the Cube every time you change parameters? Or just after some parameters?

im a little out of date apparently
The setting of the orientation of external compasses is no longer required. It’s determined automatically during calibration now.

Yea, COMPASS_AUTO_ROT, enabled be default, sorts this.