Automatic Takeoff

Please tell me, the plane in the “TAKE OFF” mode takes off badly. The plane just doesn’t have enough thrust… In logs it is visible that the autopilot too early throws off the throttle, I can not understand why?

Log of this flight:!AgyvhCRrlh2RiU0S8u8kkzHNgZtT?e=KMQUG4

No one knows the answer to my question?
Can someone tell me why the throttle level can be limited before the height of “TKOFF_LVL_ALT” is reached ?

I’m really new at this but I don’t see any airspeed sensor information. I would think that would be critical for auto takeoff before the plane can estimate winds. My guess is that without an airspeed sensor it assumes it is going at TRIM_ARSPD_CM when it is at TRIM_THROTTLE.

There is no airspeed sensor on the model.

A plane without an airspeed sensor is like you being blindfolded while driving a car.

1 Like

Ah, but… with a GPS you know ground-speed… which is how at least two ‘dumb’ autopilot/return to home units with auto-launch work… and they don’t have air-speed sensors! :stuck_out_tongue:

Yes, I am that person :laughing:

I have the exact same issue, not enough trust after launch.
In my log it’s because the take off mode is skipped too early (actually I don’t even know if take off correctly detected). Xaccel is detected and right after, takeoff mode is skipped for circle.
see my post

It looks like the same for you.

If things work right, you do not need an airspeed sensor for auto takeoff. The throttle should slew to the takeoff max (probably 100%) until it’s moving pretty fast.

But you’ve already determined that it’s not an issue with the behavior within takeoff mode, but that the mode is changing to circle. One thing that might be involved is that if Arduplane believes a takeoff is complete, switching back into auto will only partially start over with the takeoff command, i.e.,

  1. The motor(s) will start on x axis acceleration exceeding the trigger value

  2. The mission will execute the next step. Pretty much, this will never be the Takeoff, since that’s always the first step. If there is a circle in your mission, this could be the reason that it proceeds to do a circle.

You can figure out if this is the problem. Step one, as is often the case, is to remove the prop(s). Once they are off you can jiggle the plane to trigger the auto takeoff and observe the modes. Or…if you have a circle in your flight plan, just take it out and put something else in there. If it continues to get into circle mode, my advice is off base.

My solution to my problem was to use the reset mission channel parameter to assign a TX channel to reset the mission back to the start. It’s easier than removing and replacing the battery.

 RST_MISSION_CH: Reset Mission Channel

 Note: This parameter is for advanced users

 Enables a channel to reset the mission to the first waypoint. 
 Mission restart is triggered by channel rising above 1750 PWM. 0 disables.

Hello everyone
I use an APM 2.6 WITHOUT Speed ​​Sensor on a SkyWalker X6 flying wing on which I have programmed the Auto Takeoff (Shake Off).
Everything works correctly except that I cannot achieve that at the time of takeoff it only uses 68% throttle and not 100% as I believe I have indicated in the corresponding values.
When I push manually the throttle to 100% in FBWA for example, the motor throttles correctly to 100% but in Shake Off I can’t get it to full throttle.
Can someone help me find the solution?
Thanks So Much

Here some .param dates relationed with Throttle and TakeOff

TRIM_THROTTLE,32 (maby this is the guilty)

I try to activate or desactivate Trottle_nudge and nothing change
I try to chane tkoff_thr_max to zero and no changes

I compared the behaviour of TAKEOFF as a flight mode and TAKEOFF as the first item of a mission. I observed significant differences. I’m looking for an explanation but have not yet found one. If anyone has anything to add, please add it to this thread…

Re reading the Arduplane documentation for auto takeoff and reviewing videos of my channel
when Fail Safe enters the RTL (in minute 6:35 when RTL it was activated), I have noticed that APM never uses high values ​​of THROTTLE.
I don’t think I can fully understand these parameters:

TRIM_THROTTLE (I have value 32)

TROTTLE_NUDGE (i have value 1 activ)

Perhaps in that combination of values ​​is the solution to my problem.

Is there someone who can help me?

Trim throttle is the percentage of throttle required to achieve level flight. It is used when there is no airspeed sensor being used.

Throttle nudge is used to increase the throttle to the maximum airspeed that can be achieved by your aircraft, specified as fbw_max. While in throttle controlled modes such as auto, this can be used to increase airspeed.

Well, in the end I answer to myself and record the solution in case the same thing happens to someone else.
The solution was to modify the TRIM_THROTTLE parameter that had it at 32% and by taking it to 100% the autopilot raised the throttle to 100% and by setting it to 75% the autopilot raised the throttle to 88% averaging 100% by TAKEOFF THROTTLE MAX and TRIM THROTTLE

Thanks Sunny52266 for the answer, problem solved¡¡

1 Like