Servers by jDrones

Automatic flaps not deploying

I’m having trouble with automatic flap deployment during takeoff and landing. I have my flap servos on RC9 and RC10, set to flap_auto (3), and my flap input from the transmitter is coming in on channel 7. Manual flap control works fine in all modes. I have tried LAND_FLAP_PERCNT at both 0% and 100%, and TKOFF_FLAP_PCNT at both 30% and 60%. None of these settings seems to deploy flaps during automatic takeoffs (hand launches with the motor running prior to launch) or automatic landings. A log file and config file are here:

drive.google.com/file/d/0B6c7J- … sp=sharing
drive.google.com/file/d/0B6c7J- … sp=sharing

During the flight, I brought the airplane into auto mode, which powered up the motor but did not lower the flaps. I brought the flaps to 50% manually for launch, and retracted them manually after launch. During the first automatic landing attempt, the flaps did not lower so I lowered them manually, and retracted them incrementally during the landing abort. I did not touch the manual flap control for the second landing attempt, until after the aircraft was on the ground and I did two quick full flap extensions to check for manual control.

Interestingly it appears that both the C7 input and the Ch9 and Ch10 outputs have a slight movement at the beginning of both landing sequences, but it’s only changing the output by 100 uS. I was definitely not moving the flap control at that point. Any ideas? I’m flying a pretty slick airframe and the flaps are necessary for accurate auto landings.

@mrjadkowski,
I have alerted our ArduPlane software developer to your issue.
Regards,
TCIII GM

A quick update: I changed the flap servos to RC7 and RC8, after reading somewhere that flaps won’t work if they aren’t on RC1-RC8. I test flew it and it had no effect; the behavior in flight is exactly the same.

I haven’t forgotten about this. I just need to finishing building my plane with flaps so I can test :slight_smile:
Thanks, Grant.

Has this been fixed? I can’t seem to get my auto flaps to work either.

I did eventually resolve this; it had to do with the autopilot interprets flap commands. Basically, the autopilot will always assume a low or high PWM signal (I don’t remember which) is down flaps. I had my servos and reversing set up so that I was giving it that “down flaps” signal to physically raise the flaps, and the autopilot was interpreting that as me overriding auto flaps all the time. I don’t remember the magic combination of reversing on the transmitter and autopilot but eventually it started working correctly.

It actually happened to be a bug with the autopilot system. It was an issue with prelaunch settings. I have a pull request into ArduPilot and hopefully it’ll go through!

Can you explain this in more detail? I can not understand

Thanks

Servers by jDrones