Servers by jDrones

Autolanding & Flaps


(Atico) #1

Hi, I want to use the flaps in autolanding with arduplane but I can not get it.

LAND_FLAP_PERCNT = 100

FLAP_1_SPEED = 0
FLAP_2_SPEED = 0

Any hint?


(Atico) #2

I think I was missing this command:

SERVO5_FUNCTION = 3

I had it set to 1.

I will try it in flight


(Atico) #3

I also can not automatically display flaps in autoland with these parameters.

Any suggestions?


(Atico) #4

Flaps work correctly during the flight setting FLAP_SPEED 1 & 2 but I want to move them only during the LAND.
Even if there is a LAND_FLAP_PERCNT command, I think it is necessary to implement something else so that they only move in LAND