Autoland does not work for me

I do not know if it is a bug
I am not able to get successful autoland result. Am I overlooking something?
Can someone help?
The plane is a Twin engine AlbaBird 7

It flies well using the latest Arduplane. Hardware Pixhack 2.8.4
My log here 1
My param

Could you please describe your problem here?

I’d set up latest waypoint in auto mission as landing and it start working out of the box.
I’d adjust Flare altitude to 10 meters. No more adjustments were made.

In this video I’d missed flare altitude (too low) but autolanding works…

your RTL_AUTOLAND is zero.

you need:

I recommend:

I like:

I have other planes with older arduplane versions with RTL_AUTOLAND=0 and landings are normal.
If you have a look at the landing airspeed it is very low vhile in the parameters I set it high.
It is like te landing airspeed setting is ignored during autoland. The plane looses speed and crushes.

RTL_AUTOLAND=1 is used when you press RTH, it will automatically go to landing sequence …
So you mean landing with a mission setup ?