Auto waypoint places DO_SET_CAM_TRIGG_DIST in wrong sequence when adding lead in/out

Hi Everyone,
I have three laptops using MP for aerial surveying. One has 1.3.70 and Auto WP with lead in/out works fine. All triggers are within the polygon.
However the other two have been updated to 1.3.72 and both place the trigger command (DO_SET_CAM_TRIGG_DIST=0) late after the lead out waypoint (the next waypoint) giving some intersting results on the final processing. Lead in trigger sequence is ok.
Is this a bug?
Is there a way to roll back MP versions? (this part solved)
Uninstalled MP ver 1.3.72, loaded 1.3.71 msi and same problem.
Uninstalled 1.3.71 and loaded 1.3.70 and Auto wp planning was ok.

can you give me an example poly file or the settings you are using.
or just the planned mission on both versions for comparison?

Thanks for looking into this Michael.

Attached are the screen shots of the steps i take to create the mission.
If you notice waypoint 5 on both cases, one is created with the camera trigger straight after waypoint 5 (the good one) and the other is created after waypoint 6 instead. The lead in trigg
command is correct for both cases.
The processing still works but there are a lot of unessesary photos taken .
Manually moving each waypoint / trig takes quite a while and this poly is just a small one where usually they are 5 or so times larger.

survey grid 2

ok so the cause of this is a change i made to try get around a copter issue and leach length.

and as you have seen is to do where the DO_SET_CAM_TRIGG_DIST gets inserted

Ah. OK.
Is there a need for a new version or beta to come out or do I need to request something?
My workaround at the moment is to resort to uploading the older MP to get the Auto WP to behave normally.

Can you try the latest beta mp?

The latest version of MP has solved this issue, thanks Michael!