Auto Trim: Spontaneous roll mid-flight

After many long months I have finally gotten my quad up and running. After a successful test flight with stock PIDs, I decided to give the Auto Trim a go. Set everything up, and got up in the air. Maybe 10 seconds after a hover, the quad would suddenly bank left, applying throttle as it did so, and I would have to cut it to avoid hitting my shelf. I thought that maybe this was a one-time thing, so I tried Auto Trim again. Same results. I have attached the log file of my second try, with a video of my first try (because the second had the camera facing wrong due to the hard landing). I have not tried to fly it since because one of my skids broke on the second try and it is fairly windy outside.

Any input is greatly appreciated.

Video: (0:33 Second Mark) [youtube][/youtube]


You’re hovering with a 10 degree roll… Can you take a photo of your setup? Is the board not level on the copter?

A possible cause of twitching is your low THR_MIN. Please raise it back to the default.

THR_MIN was altered because I was playing around with a sensitivity issue. The difference in speed between my throttle at 0 and my throttle at what I would consider the smallest amount of movement I can bring it up was too great. I tried some settings in APM before I realized that I had changed my ESC settings. Set the ESC back to normal and I was fine. Just forgot to change the THR_MIN back to default (because I didn’t notice a change in anything).

I have attached photos of my quad setup. Don’t mind the broken arm, that was from something that happened here: … e=activity which I’m guessing is that my APM misread my battery voltage, went into RTL failsafe (I don’t have a compass attached), and spun out.

I’ve decided that for a beginner, the APM has more features than I want right now. I’m going to go with a KK2.0 to learn how to configure and fly, and then go back to APM when I have more time and experience.