Auto takeoff + do_jump (strange behavior)

few days back i checked for the very first time the “do_jump” function to force my plane to keeping on repeating the mission of two way points.
there was strange behavior that i wasn’t accepting…and it was very alarming too. here are details
i created the mission with following steps

  1. Take off (alt=20m, pitch=18)
  2. 1st way point with alt=55m
  3. 2nd way point with 55m alt. (both way points were about 150m apart at 180 degree to each other with home in center)
  4. 3rd was dummy way point and selected do_jump (repeats= -1)
    ok, the plane took off in auto, reached the way point-1 and than to 2nd way point. and after 2nd way point the plane started losing altitude and reached to almost 20m, afterward planed pitched up, acceleration increased and reached the way point-1 and attained 55m. then went to way point 2 and after reaching waypoint-2 it behaved the same by losing altitude and when reached to altitude of almost 20m it started pulling up. i thought some when wrong by me during mission planning. so, today i checked it again but setting takeoff target altitude of 30m to prevent it from striking the near by trees. the plane did the same. attached tlog is of today’s flight
    i think this may be due to altitude variables in main code… :astonished:

setup details:
APM 2.5 with firmware: 3.01 (latest stable),
Scratch Built rudder only plane
sorry for bad english

with best regards

Looks like it also repeat the take off process… Have you tried to remove the auto take off? Take off manually and then change to auto in the air.

I had a similar thing happen to me today. I hit reset mission while airborne and it actually did another auto takeoff. It’s never done this before. Usually it will skip auto takeoff if already airborne and go straight to WP2.
Plane 3.02

@ zhoter, no, i never tried do_jump (repeats=-1) without auto takeoff. yes, i will try mission repeat option with out take off in future. now a days i am repairing my plane which crashed while trying first time "follow me " option using mission planner with bluetooth connected cell phone.
@ iskess, it should not repeat auto take off while repeating mission otherwise it may end in bad crash. its a bug, i think.