Auto-Take-Off Vertical climb then loop and crash


We did more than 100 flights with auto take off with a bungee without a single problem, using the pixhawk 1 and the 3.7.0.

Lately we have upgraded 3.7.1, we did the first fight without a single problem, file 103.BIN. Before the flight AHRS orientation was always correct, external compass was not (once). We set primary compass to internal at that time.
The parachute landing was a bit tough with the parachute due to strong wind, we lost the stopper of the folding propeller.

We tightened the propeller very well without the stopper and we tried to do the auto-take off with the bungee, but the plane went very stiff vertical and then it tried to stabilize itself but then we opened the parachute but it was too late and it crashed. file 106.bin

We did a new plane with a new AP and an APC propeller, we did all calibration and we checked all the surfaces before flights and everything was OK.

we tried a simulated “takeoff” by setting takeoff altitude to 2 meters and raising the frame in auto mode; it completed “takeoff” and leveled off.

But upon real takeoff it kept climbing and tried to do a loop and then a crash.

And if you see in the log, pitch is past the takeoff angle but NAV_pitch does not level off. 24.bin

We need please to know what is the issue, because all our flights and take off with bungee are the same for the last 3 years.

The only changes that we did was some extra mission with Do Landing, the first time with parachute 106.bin and the second time auto belly landing 24.bin .




Plane V-Tail

Airframe type

Fixed Wings V-Tail Talon

Hardware type

Pixhawk 1 with arduplane 3.7.1






I’ve had a quick look. The two questions I’d seek answers for: is pitch stabilisation operating in the correct sense? and were you tail heavy? (smaller than usual battery perhaps)
I’ve assumed you have the v tail on Ch2 and Ch4.

VTAIL_OPTION is the param you need to check by the way. Can reset to 1 after a firmware upgrade sometimes

You’ll know if you’re tail heavy if your pitch PID.I value is getting big. That means it’s having to add more and more pitch to compensate for normal flight it will eventually level off at the senses offset value but it would be bigger than other flights.

The integrator goes negative (out to -17 or so) in this log - which leads to VTAIL_OPTION or reversals not being correct I think, as negative I with uncontrolled pitch up doesn’t make sense otherwise.

I think it may be the wrong log? Ground speed doesn’t go above 1.4m/s in 24.BIN

it turns out the takeoff is in 23.BIN


For some reason the aircraft didn’t respond to the pitch output on the VTAIL. The VTAIL_OUTPUT option is set the same way as for 103.BIN, so if the servos were connected the same way it should have worked. I can’t explain why it didn’t, sorry. The log shows the stability output was moving the servos correctly.

The only changes has been made are:

1- upgrade to 3.7.1
2- Installing RFD900 and it is connected to the servo rail of the pixhawk 1

The power is always the Castle BEC Pro 20A

We are trying to suspect that the servos has been saturated because our MIXING_GAIN is above 0.5, it is 1.0, but it was like this for the last 2 years without a single problem.

Without having looked at your logs, powering the RFD900 directly from anything that is powering other avionics is a bad idea if you are running it at 1Watt. There can be ground lifts associated with the high power draw, that can show up as noise across the system. For example when I did it by accident it was causing large fluctuations in the ADC’s monitoring the battery power, and resulted in different ground values across the system. If you have servos that are sensitive to the PWM range, then the possibility of ground lift could have meant they just weren’t receiving a signal reliably.

Try powering the RFD900 directly with it’s own dedicated BEC.

We did 1 flight 103. BIN with the same configuration without a problem and the RFD Antenna was even near the Servos and we didn’t have an issue.

in Flight 23.BIN, the antennas were on the front and we have the same issue of vertical take off.

We just did a ground test with and without the RFD and there was no interference.

HI, Have you found the problem, i am getting the similar problem, airplane rotates before reaching takeoff altitude
my log file and picture here