Auto Problem in 3.0.3

Hi all,

I hope someone is willing to help a newbie here because I need it… Here goes:

I cannot get my plane to follow a GPS flight plan. The weird part is that back in January 2014, with the same APM and GPS, I was able to fly missions no problem. I have updated both the APM firmware and the Mission Planner. Has anything significant changed while I’ve been away from the APM that would prevent me from being successful?

Here are some more details:
My set up today is a 900mm Popwing with a HK APM 2.5 with a HK uBlox GPS receiver. Power to the APM is supplied through the 2A BEC in the ESC. No telemetry.

When I plan a flight in Mission Planner, (Oborne’s 1.3.7) it writes and reads to and from the APM just fine. The Grad% is reasonable and the absolute altitude box is unchecked. When I write the waypoints to the APM, download a log, and view the .kmz, it shows my ground track in each flight mode, but does not show the waypoints. The last time it worked (January) it showed the waypoints as part of the .kmz. Has this changed from the January versions? (pre-2.74b on the APM) I should also add that I had to set the home altitude to zero before every waypoint write back in January, or it wouldn’t work. I’ve tried that now (August), and it has no effect.

When I switch into Auto, the plane has a varied response. Sometimes, it turns toward the first waypoint, and sometimes it doesn’t. The only constants are that it dives at the ground and shuts the motor off. I can slow the descent since I have FBW mixing enabled, but whether it heads to the waypoint or just dives seems completely random.

Every other mode works perfectly. Both FBW modes perform as expected, RTL reliably brings it back (except that I had to set ALT_HOLD_RTL to -1 or the plane climbs into oblivion), ACRO holds attitude, etc…

If someone could enlighten me to my problem, I would be very grateful. If you have any questions about the problem/setup/etc, I’d be more than happy to answer.

Thank you for helping someone new,


The problem is that the autopilot will not follow a series of waypoints set through mission planner. I expected it to fly sequentially from one to the next, (WP1 to WP2 to WP3, etc… until the final WP, then into RTL) but it does not do that. When I change the mode of the APM to “Auto” mode, the motor shuts off and begins a descent which it does not pull out of. Sometimes, it turns toward a waypoint, and sometimes it does not.

My board is a Hobby King HKPilot Mega 2.5. (A clone of the 3DR) The GPS is a Ublox LEA-6H GPS module. The compass is internal. There is no power module, airspeed, telemetry, optical flow, sonar, OSD, camera or FPV. The airframe is a Nitroplanes 900mm EPP Popwing with a Turnigy 30A Plush ESC, a OrangeRx 620, and an Optima 300 outrunner brushless motor. The servos are two Hitec HS-65MGs and the prop is a 7x5.

The HKPilot is running ArduPlane V3.0.3. My computer is running Michael Oborne’s Mission Planner 1.3.7.

I have also attached a few data logs.

Thank you,

I have fixed the problem of not seeing the waypoints in Google Earth by only creating a flightplan on a fresh start of Mission Planner and with the APM disconnected. Then I download the KML file from the “View KML” link on the planning page and open it in Google Earth. I have attached a screenshot of what I see.

Unfortunately, the plane still dives at the ground and shuts the motor off in Auto mode. At least now it always turns toward and glides/dives at the waypoint. Despite often crossing the waypoint, it does not turn toward the next waypoint.

I think it might be that the barometer is uncovered and that the slipstream is changing the ambient pressure.

Any thoughts/ideas would be appreciated,

Or maybe I didn’t attach a photo. Here it is.

Just got back from testing, and I’m pleased to say that taping a piece of tissue over the barometer fixed the issue. The plane now holds altitude and will climb or descend as necessary to achieve the planned altitude. I knew this was is well know issue, but I thought that the recessed position of the APM was enough.

Just to recap:

  1. Planning a flight on a fresh start of Mission Planner with home elevation set to zero fixed the .kml file not showing a route.
  2. Taping a piece of tissue over the barometer fixed the altitude hold issue.