Auto Mode Speed and Acceleration

Although I set the speed of 20 m/s from WP Nav in autonomous mode via Mission Planner, it flies very slowly. What can I do? Could it be a problem with acceleration? I didn’t change any values ​​related to acceleration.
Thanks in advance.

By saying slow, how much m/s?

Could be, and also angle limits, but first, the vehicle must be tuned well.
Can you post on-board logs, and also give some info about hardware setup (motors, propellers, frame, battery voltage, etc.)?
Also by saying:

Do you mean the parameter WPNAV_SPEED?
This parameter’s unit is cm/s, BTW, so it should be 2000 for your case, but it is a bit high value, don’t set it to 2000 immediately, do some test and gradually increase it.

1 Like