Auto Mode Rover Spinning in Circles

My first foray into rovers from building copters. I have finally got the Rover to arm after disabling some arming checks. The first attempt of an Auto Mission (via Tower) has resulted in the unit spinning in circles. I’m new to rover, be gentle.

1 Like


If you were using MP instead of Tower, I would have recommended checking the “reverse” box next to the Roll bar in the Radio Calibration page.

However, you might be able to accomplish the same thing by setting the RC1_REV parameter to -1 assuming that RC1 is your steering servo output.


1 Like

That worked! Excellent. Thank you.

I am having this same problem in Rover 3.4.2 318a941d. I tried to check the reverse box in ROLL but it still spins in AUTO.
RadioLink Pixhawk
RadioLink at 10 trx
sabertooth 2x60 controller
2 24vdc wheelchair motors
When I reverse the roll it make steering right & left reverse in manual mode .



Symptoms include
Auto mode rover turns and spins left for several seconds then slows abit and software said “crash going to hold”

I think we discussed this in another thread… but in any case, it’s likely that either SERVO1_REVERSED and/or SERVO3_REVERSED is set incorrectly. It can be checked using the MP’s motor test screen.

Randy: I did as you suggested and you are correct . The motors when test C is pressed
Motor turns mower right & test d both motors go forward.
Here is a LOG file.
If you care to look.


OK, something is certainly wrong, probably with the ESC/motor board setup. The “Test Motor C” button should only make the left wheel turn forward. “Test Motor D” should only make the right wheel turn forward (see note in red on the picture here).

Maybe the vehicle is a skid-steering rover but the ESC/motor driver board is setup to treat it like a regular rover (i.e. separate steering and throttle). This issue definitely needs to be fixed before anything will work I’m afraid.

Hi Jimmy
I’m having the same issue but the problem did not go away

You have to make sure that the motors are set up correctly. Put the unit up on blocks and test. The replies above are from the experts. You need to set the wheels correctly by using MOTOR TEST in Mission Planner. If you can reverse wires instead of checking the REVERSE box on the ESC’s it would be best. Most of the time it’s just one little missed detail. Remember: There are NO assumptions when dealing with Ardupilot.

1 Like

Hi Jimmy
I think it’s a case of starting again flash the module reinstate all settings back to default. Maybe use rover 4.0.0 this time and not the beta version

I have same problem when I setup CubeOrange…
Did motor test, The “Test Motor C” button only makes the left wheel turn forward. “Test Motor D” only makes the right wheel turn forward.

What is wrong. Rover 4.0

Since Motor Test should test individual motors, what you describe is exactly as it should be.

press button C, left wheel spin, press button D, right wheel spin. when switch to Auto mode, the rover spins. not follow way point.