Auto mode no error but motor don't start

Hello to everyone, i am using Pixhawk 2.1 + Here GPS and Mission Planner as software. I use also turnigy esc and turnigy motor. Is my second fixed wing (before with pixhawk) but i’m trying to make pixhawk 2.1 working for surveying mission. I got no error when arming motors and in fbwa is flying well.
The problem is that when i put in auto mode for waypoint mission servos moving ok but no motor spin.

Down there is a log where i change between fbwa mode and auto mode but the motor don’t start.
thanks in advance for attention.

the file can be downloaded from here:

the link is from wetrasfer…

I’m taking a look at your log… Was the plane flying when you switched to auto mode? It looks like this log was just the plane sitting on the ground… does that make sense?

Thanks !!! Yes the plane was sitting on the ground without props today.Yesterday i was testing fwba mode and all all was good (motor servos ecc…) but for my work of surveying auto is needed to working well and yesterday in auto motor don’t start and today try to solve the problem but with no result…With the same frame some motor , esc ecc. with pixhawk “1” all working well…it seems that when i switch to auto motor is not having the impulse of start…


It would be unsafe if switching to AUTO mode with the plane on the ground made the propeller spin. ArduPlane has safety logic specifically to prevent this. So I am not surprised that it did not spin while you were on the ground.

If you have a valid mission programmed, try taking off in manual mode, and switching to AUTO once you are safely airborne?

Ok thanks for suggestion, this afternoon will make some other test…

what I do for auto takeoff is this:
CRASH_DETECT 0 => current code buggy

then I do a fake throw of the plane while holding it, verify that the motor does start, and then throw the plane for real

Hello thanks for your suggestion !!!. Today finally i have time to make some tests but the problem persist. When i’m using fbwa mode throttle respond good with motor that spin and no error for now. In auto mode (i was in the field) it put elevon in right position but motor don’t start. I noticed that i can not do esc calibration because MP say “Set param error. Please ensure your version is AC3.3+” ??? can be this the problem?.
In pixhawk 1 neved had this kind of problems only with pixhawk 2.1. I set also arming_rudder = 0 Params_240717.param (11.5 KB)
Can someone look at my parameter files if there is some thing wrong?

Thank you all for the support.


i was also set TKOFF_THR_MINACC 10 but motor don’t start anyway

When I loaded your param file, it suggested that 52 parameters are missing. Unfortunately I can’t copy-and-paste the list, but



Was the list in alphabetical order. Can you instead post a log-file from that flight which will tell us the firmware version and parameter values?

Ok, i was doing another test right now…what i do: 1_ Plug the battery 2_Wait for 3dgps 3_Precalibration 4_Sending waypoint 5_Arming 6_ Check in fbwa mode that all servos responds well and motor start 7_Throttle to lower point 8_ Start auto mode

The plane put the elevon in the right position but motor don’t spin.

I change from fbwa to auto several time but nothing happend and no errors…

You can download all the logs (pixhawk and mission plammer) and .params file here (wetrsfer)

Thanks for support


If you set the MINACC to 10, the motor will not immediately start when you switch to AUTO mode. Please carefully read the description of the MINACC parameter and post back if you have questions.

(Hint be very careful! If you physically shake the plane in AUTO mode, the prop may start spinning. This is a threat to your safety, if you do not understand what the MINACC parameter does.)

I was trying with TKOFF_THR_MINACC 10 but without success so i return back to 0 and in the last test was 0 but in auto mode motor don’t spin, with pixhawk 1 there was not this problem.

Thank you for explaining, sorry I missunderstood. I’m looking at your log, and you’re right that


I also see repeated switches from FBWA to AUTO with no C3 output, and I see where you were able to spin the prop in FBWA in the same log. (C3 output goes above 1085, as high as 1517.)

I don’t yet know how to find out why the auto-takeoff isn’t engaging for you, so I’ll have to learn as I search. Perhaps someone else knows where to check and can help you sooner? If not, I’ll post back when I figure it out, but it could be a few days…

Thanks hunt0r , tomorrow will do some other tests with collegue and will write the result .


I admit that I don’t understand all of how the auto-takeoff code works. If someone who has a better understanding can chime in, that would be best.

I noticed something odd in your logfile: there are 0 ARM messages. As I understand the code, when you arm or disarm the plane, it should log that event. The throttle will not (or… should not…) spin without arming first. Did you arm your plane during this log? If yes, I wonder why it wasn’t logged? If no, try arming it and then trying the auto-takeoff?

(I’m not sure how you spun your propeller in FBWA mode without arming… You did spin the propeller, right? So maybe not having ARM messages isn’t a problem, and I missunderstand how those work?)

Finally now all is working well. The error that i made is to load .params file from previous configuration with pixhawk 1. Settings the single param one by one all went good, despite of this i don’t understand whick param go in conflict with pixhawk 2.

Thanks you all for support.