Servers by jDrones

Auto Landing retract


(legend1996) #1

Hello, having a small issue, thinking I am missing something…I have set up many APM’s, Pixhawks and now have put Pixhawk 2.1 on all of my Multirotors. I just finished an 2.1 install on my Tarot X4. Flies flawless. Did an Autotune and was very impressed. Here is the issue: I have the landing retracts set to channel 7 and servo10 which is Aux 2 as you know. Gear servo plugged into Aux2. The retracts function as they should except for RTH. When I initiate a RTH the gear does not deploy at the Loiter above home point stage. I can’t at that point lower the gear with my channel 7 switch so I land in stabalize or acro and put the gear down with switch. Anything I could be missing here? I am way below the upper and lower PWM’s. Running 3.5.3. Thanks, JEFF


(Matt) #2

Does it auto deploy properly in land mode? I’m guessing not since the same code detects that too.

Parameter SERVO10_FUNCTION needs to be set for 29 (landing gear). Not some kind of servo pass through. The servo output(s) set for 29 will respond to both the gear switch and the automatic deploy.


(legend1996) #3

Hi, No it does not deploy in Land mode either. Servo10 is set at 29. Could it have to do with the hardware or could I be missing something. Thanks, Jeff


(legend1996) #4

Surprised no one has any ideas on this? I have been an Arducopter user since the beginning. Changed everything to 2.1, 6 units. Would appreciate anything you could think of. I have changed the landing gear and controller. Not necessary but did it to rule out a mechanical issue.


(legend1996) #5

Problem is fixed. I needed to switch the retract and deploy parameters. Copter was trying to retract when it was landing when it needed to send PWM for deployment. Swapping the two number worked!


(Matt) #6

Ah, I thought I replied last week about that. The same thing happened with the retract kits people were putting on Solos. The servos on the retract kits were backwards from the default parameters in ArduCopter.