Servers by jDrones

Auto landing gear deploy in RTL - setup confusion (Pixhawk)

Hi all, new to the forum. Thank you all for your great contribution.

I have two copters, one X8 and one hexa (Tarot 680Pro), both controlled by Pixhawk with arducopter 3.4
Radio is Taranis, and receiver(s) are X8R using latest EU firmware.
Receiver connected to Pixhawk using SBUS for all channels CH1-CH16.
Receiver also setup to provide CH9-16 out on X8R for manual connection of peripherals.

I want to setup the landing gear feature so that the landing gear auto deploys on RTL/Land.
From what I read, this now (3.3 RC6) works. But I am unable to get manual control at the same time as configuring an AUX port for the landing gear.

I have searched, but I am unable to find a specific answer to this. This should be so logic, however it is not, to me.

I am planning on using AUX1-3 (CH9-CH11) for gimbal pan/tilt/roll control.
So AUX4/CH12 is available for landing gear setup. (To my understanding AUX5-AUX6 is not working, unless enabled as RELAY). But I am fine with AUX4. Will control camera trigger and gimbal mode directly through X8R.

According to ardu wiki I should then setup RC12 function to 29 (for landing gear) so that controller knows where landing gears are connected when RTL/Land is enabled, and then setup CH7 or CH8 for manual landing gear control.

Landing gears are powered by separate BEC providing a stable 5V, and a separate connector with signal only controlling the state of landing gear.

Landing gear works if I connect them directly to X8R receiver, or if I connect them directly to AUX4 (CH12) on Pixhawk/Pixraptor, and enable RC12 function 1=passthrough, or 62=RCIN12 (ch12 is my landing gear switch on radio).

But when setting RC12=29 (for landing gear), there is no way I manage to also getting manual control over the landing gear. I have tried setting Ch7, CH8, and even other channels to 29 (landing gear) (and of course checked and used the correct corresponding switch/channel on radio)

Right now I have set CH12=29 (landing gear) and RC12=62 (Ch12 input), and I am able to manual control the landing gear via AUX4 on Pixhawk. I am unable to test if auto deploy works due to heavy weather here now, but according to wiki setup it will not work unless RC12 is set to function 29, so currently I only have manual control of the landing gear.

If I set eg. CH7 to landing gear, how does the controller know that the landing gear is connected to AUX4 when I use CH7 switch on radio? By setting RC12 = 29 ? Obviously not, this does not work. There is some missing link here. The controller does not pick up the inputs from CH7 and forward them to AUX4.

What am I missing here?

How should I setup to get both auto deploy in RTL/Land working, as well as full manual control?

Any help will be greatly appreciated.

1 Like

Hi, I have exactly this setup on my own Tarot 680Pro, and have it working perfectly. This is what you need to do (what is set on mine anyway):

RC12_FUNCTION = 29 (Connect your landing gear to AUX4)
CH12_OPT = 29 (Signifies that your Ch12 input, will control the landing gear If you want to use ch7 input instead, then set CH7_OPT=29 instead)
LGR_SERVO_DEPLOY=1000 (set to suit your retract servo control)
LGR_SERVO_RTRACT=2000 (set to suit your retract servo control)
BRD_PWM_COUNT=6 (this enables all 6 AUX ports - I suspect this is what is missing from your configuration)

As to how it works (your last question), I would suggest that the RC12_FUNCTION=29 setting simply tells pixhawk which channel to output landing gear PWM to when it is required (in RTL/Land etc), and CH_OPT=29 is specifically to specify which input channel it will accept landing gear input from. It passes the input through to whichever aux port you specified for RCn_FUNCTION=29.

The way it works in practise. I take off, flick the switch to retract, then if RTL is called, it will return and as soon as it hovers above the home location, the retracts come down. It then lands - but all this time, my switch is still flicked to have the gear retracted, so the FC has overridden the switch as it required to do by the RTL. I then need to flick the switch back up - so the next time i flick it down it will retract again.

2 Likes

Dear Paul, thanks for your input. I am with you and I tried exactly what you say, RC12 (AUX4)=29, and CH7_OPT=29.

However it does not work when testing at the bench! Switching CH7 does not manually deploy/retract landing gear.

Are you telling me that the copter needs to be airborne for this to work? If so, it should be clearly stated in the wikipilot.

Regarding enabling the last two AUX ports using BRD_PWM_COUNT=6, I have tried this earlier, and it does not work. I have never been able to enable to last two AUX ports (5+6), but that is another discussion and not needed for enabling Landing gear as long as I am using AUX4.

Hi

The AUX functions can be “blocked” (Copter 3.4.x) when testing on the bench. There’s a new option that can enable the bypass for the AUX when not armed.

http://ardupilot.org/copter/docs/parameters.html#brd-safety-mask-channels-to-which-ignore-the-safety-switch-state

On your case, try to test without props by arming. Or at least use the safety switch.

Ah, I would have never noticed the effect of the new safety mask, as I have never used the safety switch since day #1 :slight_smile: I have always had the setting BRD_SAFETYENABLE=0 on all my copters, and hence the retracts work on the bench just fine for me.

Dear Luis, thanks for your reply.

For a moment I was getting my hopes up here, just to be disappointed again.

The BRD_SAFETY_MASK does not make any sense to me. There is only one line with a five digit value of 16320 here.
It does not correspond to the table in your link.

Hitting the safety switch did not help either, so I dismounted my propellers from the copter.

Armed the copter, started motors up to 50%, lifted the copter up using my arms, and tried to manually retract landing gear.

No such luck. Does not work. I am not able to manually use landing gear.

RC12=29, and tried with both CH7, 8 and 12 =29…(and with corresponding switches on radio)

In a few hours I’ll be able to send my relevant parameters to compare (but from memory the settings above are correct and the wiki too), but are you sure you are sending the values on the right radio channel ??

I believe I’ve sorted this LGear issue previously to other user here

Luis, yes I am sure.

I have my Landing Gear setup to Taranis switch SF (Input14 - Output12).
I have Ch7 on switch SA and Ch8 on switch SB.

I have tried using CH7 (SA), CH8 (SB) and CH12 (SF), with CH7OPT=29, CH8OPT=29 and CH12OPT=29, along with RC12=29. Nothing helps. I am unable to retract landing gear manually on the bench unarmed, armed or airborne armed.

If I set RC12=1 (direct pass-through of Ch12) or RC12=62 (RCIN12), or RC12=57 (RCIN7) or RC12=58 (RCIN8) then controlling landing gear from respective switch from radio is working. So radio is definitely sending out the right channels. This is also confirmed by looking at channels under radio calibration in Mission Planner.

This is so frustrating! And the amount of time required to get a simple function like this up and working is annoying.

There must be something I am missing.

My settings on the Hexa that correspond to the radio settings above:

1 Like

Sorry for the late update.

This is so weird. I got this working on my X8, but not on the 680Pro.
The X8 had a genuine 3DR Pixhawk, the 680 a derivative (Pixraptor).
I figured it had to be something wrong with the Pixraptor, so I moved the Pixhawk over to the 680.

But same issue, still not working with the genuine Pixhawk on the 680.

Which leaves me to consider it has to be something with the the landing gears (Tarot TL65B44) on the 680, or how they are powered.

The landing gear is powered by a separate 5.5V BEC. and signal cables from the two legs are soldered together and connected to AUX4 (RC12) on the pixhawk. When I set RC_12_FUNCTION = 1 pass-through, both legs are responding to CH12 switch on radio.

The second I set CH12= 29 (landing gear) and RC12_FUNCTION = 29 (landing gear), ONE of the legs are imediately retracted, just ONE! And then none of the legs are reacting to the CH12 switch on the radio.

This is very strange. If there were a bad solder in my retract Y-cable (either signal or power), then why are retracts responding perfectly when AUX4 (CH12) is set to direct pass-through??

The 680PRO is powered by a MAUCH power system. The X8 is powered by a regular 6S power adapter cable.

I am out of ideas. Anyone?

Can anyone confirm they have these specific retracts (TL65B44) working with the Pixhawk and auto retract feature enabled?

Maybe hook up a servo tester and see what pwm values are required to operate both retracts successfully in each direction and make sure these values are reflected in the deploy/retract parameters. Not sure what else to suggest.

SOLVED!

I connected the landing gear to one of the wheels/potentiometers on the Taranis, and measured the landing gears to respond slightly differently. One from 1230-1760 and the other from 1220-1750.

The end points for my radio was 982-2012.

Since the landing gear did respond perfectly when I did a direct passthrough (RC12_FUNCTION=1), I figured there should be no reason to mess with the default LGR_SERVO_RTRACT (1250) and LGR_SERVO_DEPLOY values (1750).

But I tried setting them to 1000 and 2000. And then both of them retracted when the landing gear switch was in deployed state (instead of just the one)

When I then switched CH12 on my radio to retract direction, then both landing gears deployed.

But the CH12 switch on my radio was in the wrong direction.

AHA! The landing gear function is REVERSED compared with direct passthrough, for some odd reason!

I reversed my landing gear switch on my radio (CH12), and VOILA!

Now I have landing gears working on both my Pixhawk and my Pixraptor with RC12_FUNCTION=29 and CH12=29

I don’t understand why the retract/deploy landing gear direction is REVERSED in the ardupilot, but it is. If it had not been reversed, I would have figured this out earlier.

Anyway, case solved.

Thank you all for your input.

1 Like

Maybe its not reversed! Maybe, you need to switch the values between LGR_SERVO_RTRACT and LGR_SERVO_DEPLOY. It isn’t always the case that retract will be the lower value. You need to be sure that when Pixhawk thinks the gear is deployed, it is actually deployed, and not retracted - then you can be sure that in a RTL/Land situation it will deploy (rather than retract). Hope you get my suggestion here.

1 Like

Paul you are right, and I understand. It may be that direction of values for deploying/retracting landing gears values differ, and in my case it was opposite than “normal to me”. Anyway I am happy it works now, and maybe/hopefully this thread can help someone else check directions and values for deploy/retract of their landing gear, and save them some time. What made this case so extra weird for me was that values differed slightly between the two legs, and value of one only one of the legs was affected by default values in ardupilo LGR function. And this made me puzzled.

On my posting above, the values I have to use for LGR are different from the default, because, my Landing Gear(s) all have a controller unit and those are the values that make the controller react. I should have been more explicit, sorry.

Paul , Quick question … I went trough it all (had the reversed state as you mention :slight_smile: ) .When land is activated i see the landing gear “deploy” this is now okay ! does this mean it will work in RTL ?..I’m still testing on the bench and not in the air ( all safety’s off).

Yes I believe it should work fine in RTL - I actually think it goes into land mode during the final descent, and this is when the gear deploys. It’s easy enough to test. Just do a RTL and if the gear doesn’t deploy then switch out of RTL to say poshold.

1 Like

Hi Paul , ill have to try it outside with GPS than …in my case RTL without GPS results in a Land…Think you are correct about the final RTL stage however …Ill will test it with GPS ( a dry not flying test first however :slight_smile: ) …Outside…
Thanks , Let you know… ( here the " Land " test https://youtu.be/YTfXqwfcsNY )

Servers by jDrones