Auto LAND in loiter mode

Hello im new here i build an f450 quadcopter with apm 2.8 and ublx m8n gps, the copter fly well in stabilize mode but when i select LOITER mode it turns in LAND mode after like 5 or 10 sec and fly away, i get solid 3D fix and have 17 satelites in view i must to turn Stabilize mode fast to recover control of the aircraft, this issue caused 3 crashes and a lot of broken props, after looking in logs i found an Err EKF CHECK 2 Err FAILSAFE EKF 1, i dont know why this happens, can some one help me to configure my quad that i can fly well in LOITER.

Also i have an FPV camera, transmitter and Microminimosd on board.


EKF is a system inside that helps with your GPS things.
Loiter requires that to work properly, so there might be an issue with ath.

It would help if you post your logs, as most people can see things from that. I would also suggest a photo of the f450 so we can see how you’ve mounted things…

Hello, here is some photos of my f450 and a biggest log i have, i can upload the other 6 logs if you want.


And also a video : (843.6 KB)

Are you sure you have your GPS connected correctly?
The APM2.8 has changed this a bit:

Original thread here:

I believe it is either bad compass calibration or the compass is not fixed properly on the frame (it can rotate a bit on that mount if the bolt was unscrewed with vibrations).

if i plug I2C under the gps i get an bad compass helth warning

Are you able to complete the compass calibaration at all?

when i try to calibrate the compas when it is pluget under the gps port i get an abnormal offsets and poits are out of the calibration screen

yes with the internal compas and external but only if i plug it in the i2c port and not that under the gps.

For a APM2.8, that’s a bit weird :slight_smile:

You definitely want the connector below the GPS connector for an external compass on a APM 2.8. Did you remove the “internal compass enable” jumper?

This is probably it.
On the last photo, the jumper is still there.

Yes in the end it was that i changed the jumper and now all things are working great.
Thank you all for the support.