Auto disarm doesn't work on 4.0.3

I noticed auto disarm doesn’t work anymore in 4.0.3.
I tried to arm the uav and let it stay there for 10 seconds but it doesn’t auto disarm. Tried 5 seconds and did the same.
Could anybody test if arming the vehicle and let it there without taking of for 10 seconds it auto disarm?

I know it should and it did in 3.6.11. On 4.0.3 it doesn’t.


Check your esc calibration.

What has it to do with calibration? It was disarming on 3.6.11

It disarms with stick or button and after auto land, it just doesn’t do it authomatically if i arm and let it there, really do not understand what esc calibration has to do with it.

Mine works. Do your motors spin up during an arm? if not you need to calibrate the esc’s.

You can configure them to spin on arming or not with a parameter change. This can’t have anything to do with ESC calibration.

I just tested one of my quads which is on 4.0.3 and sitting on the bench it will disarm after the DISARM_DELAY.

Ah I was just checking if the endpoints where set. I just built a 2.1 today and it works shuts off. He can set them manually.

As i wrote before, the quad arms and disarms without any probs. It disarms authomatically at the end of auto missions when it lands. The ONLY situation where it doesn’t is if i arm it and leave it there, it is supposed to auto disarm in a set amount of seconds but mine doesn’t. It has nothing to do with ESC calibration.

no problem, i didn’t ask you to respond :slight_smile:

I did a while ago the same upgrade from 3.6.11. to 4.0.3. It worked for me. I armed and it would disarm after a short wile. That was when my Hexacopter still had as a FC an older Version Pixhawk.
Since I changed the FC just last week some problems started of a different mater. Now after I got everything working again with a new FC ( CUAV v5nano) I just tested for you arming the vehicle and doing nothing. I can confirm it is disarming automatically after a few seconds.

Ok, thanks, so i guess i’ll look better trough my config. Maybe something bad happened to params when i updated to 4.0.3.
Thank you all for watching your hardware and confirm it works :slight_smile: