Auto Analyze error message "NumpyDotNet.NpyCoreApi

Hey guys,

Ive been having some strange issues with my quad which i wont get into here but, i thought id check my logs. im new to this and cant understand it yet. I wanted try the auto analyze button In Mission Planner (latest version (Jan2016 - cannot see where the name of the veriosn of mission planner is written) but when I press the button and load ANY of the recorded logs i get a window pop up saying - error NumpyDotNet.NpyCoreApi.
Then when i close that it is followed by " Bad input File" any Ideas? Is this a fault in the software? is it common?

I know i should learn how to read the logs but id really like this feature to give me a basic report on whats going on!

thank you
jason :smiley:


got the same problem with auto analysis in MP 1.3.35.
“NumpyDotNet.NpyCoreApi” and then " bad input file"
Have also tried to verify with the older MP version (1.3.33) to make sure it´s not a dataproblem with my logfiles but in there it works.


I also have exact same problem! Had no problems with this until I updated Mission Planner. Now I get the same “NumpyDotNet…” error when I try to use Auto Analyze. Any Ideas? Thanks…

What is the reason behind this error. I get the same


Same problem here (version 1.13.35 build 1.5878.12941), but a workaround has been posted on GitHub (issue 1127) (which worked for me). It appears that it happens when NumpyDotNet.dll is loaded from a wrong location.

Same problem with MP 1.3.35 but fixed with the version 1.3.36 build 1.1.5910.30936. Enjoy !!

MP ver 1.3.37 bld 1.1.5917.13431
Pixhawk: APMCopter V3.3.3 (acf2e10c)
MP running on windows 7 environment

Downloaded logs, select “Auto Analysis” and navigate to folder where my log files are stored I get the following error: “Error Could not add reference to assembly mtrand.dll”. After receiving this error message I select OK, and I get the message “Bad input file”. Does not matter if I select log or .bin (bin is converted to log without an indicated error). I can’t upload my .bin file since this forum no longer seems to support uploading of bin!

please do another update, some files must be missing from your install.

Hey Michael, thanks for the reply. I did not mention this but this problem is on both my Laptop and Desktop computers (both MS win7). I did update both, no change. This time I uninstalled and reinstalled MP on both computers and that seems to have fixed the issue!!??:grin:

Thanks for your help.