Servers by jDrones

AT with 360 servo problem


(Omer W) #1

Hi,

i built an AT based on pixhak and 360 servo. i can connect to mission planner with the plane and tracker together but the problem is that the servo does’nt stop rotating… i can stop it only by clicking inside extended configuration and put it on neutral…

what can be the solution ?
i used a regular servo before and it worked fine but the range was limited so i wanted to change the servo to 360…

thanks!


(iseries) #2

You can’t use a 360 servo as it is a continues rotating servo.

I normal servo rotates between 1000 and 2000 PWM for 0 to 180 degrees.

A continues servo is stopped at 1500 and moves continuously in the direction of the pulses increasing in speed as the pulses get shorter or longer.

Without feed back the controller will not know where it is positioned.

Mike


(rmackay9) #3

I think it should be possible to use continuously rotating servos. In the “Servo Type” drop-down on the extended tuning page I think there is an option for that type of servo.

The feedback should come from the orientation of the flight controller that’s mounted on the tracker.

I must say though that I’ve never used this type of servo.


(Omer W) #4

thank you
i tried to do it right now and the servo keep doing circles around itself… there is any solution for 360 tracking with the mission planner? maybe you know about other kind of servos that can rotate less than 360 but more than 180?

thanks!


(rmackay9) #5

I don’t know much about the tracking feature built into the mission planner.

The antenna tracker should work with continuously rotating servos. I suspect it’s a tuning issue…


(Omer W) #6

hey,

i configured the servo to continuously but it still rotating around itself…
i believe i’m missing something with the configuration.
MP must have a support for 360 trackers…
there is someone who did it before ?
thank you guys :slight_smile:


(rmackay9) #7

Omer,

Any chance you could download a dataflash log and post it here (or a link to it)?