Artificial horizon backwards, quad flips over on takeoff

Hi Gents. I recently bought a (used) arducopter controller (bought a used quad) and I am having a hell of a time getting it to fly. I have taken the whole craft apart and redone most of it (corrected poor solder joints, cleaned up component mounting, etc…).

I have checked and double checked motor rotation, and prop rotation. I’ve done the accel calibration, and the radio calibration and that all seems ok. However when I try to take off the motors spin up, then it flips on to its right side. Also I have noticed that when it is plugged into APM planner via USB the artificial horizon is backwards. Now before you say it, yes I know how it should work, but in my case tilting the craft left tilts the horizon left, same for right side, and when I tilt the nose down the horizon falls away, tilt it nose up and the screen fills with green. So in both axis, it is backwards. The Arducopter controller is mounting on top of the quad from, with the arrow pointing forward.

I do have an el cheapo eBay gps antenna, but is seems to get a good gps lock and once the maps finally download, it is accurate as to location. I have yet to figure out if the compass is pointing in the right direction, however it does rotate in the right direction in APM planner when I yaw the craft in my hand, and in stabilise mode I cannot see how it would make any difference if it wasn’t pointing to mag north.

so as far as I can tell, my accelerometers act like they are upside down. Anyone know if this is possible, and how/where I go to change it. I am using APM planner 2.0 on a Mac FWIW.

thanks, I am pulling my hair out at this point.

Please provide tlogs and/or dataflash logs to help troubleshoot your issue.

I just looked and it doesn’t look like I can. At least nit using the direction you linked to. Remember I am on a Mac and using amp planner 2.0, not mission planner. I don’t have that button on the flight data screen.

I did just try rotating the gps unit to what I “think” in the correct orientation, and have now managed to calibrate the compass. I’ve also tried reseting the frame type to “V” as I am using a TBS discovery clone and the layout in APM planner for that frame looks like it should be correct. No real change however. It still just flips over on takeoff. Did it a few time forwards rather than always to the right. Artificial horizon in APM planner is still all backwards.

I have found a few discussions online pointing towards a faulty Arducopter board (or rather the internal sensors being broken). Anyone know if there is any way to test for this?

The plot thickens. I have just got the 3dr radio up and running (which is incidental to this discussion but has me impressed) and aimed the compass in my eBay special gps antenna (by using the HUD in APM planner and referencing this against the compass in my iPhone). And I had a thought. as all the readings are backwards what would happen if I mounted the Arducopter backwards, so I did, and what do you know it now flies! my pitch control is backwards, despite the readings in the radio config settings being correct. this is of course still not right and while the temptation is to just reverse the channel on my radio, I can’t help but think this is all going to play havoc when I try to engage RTL and Loiter at a later date (I have only buzzed it around the yard for 5 min in stabilise mode).

So, does that shed any light? I now have the speed controller outputs at the front of the craft, and the receiver inputs at the back. And the “forward---->” marking is pointing to the back.

any ideas?


in the interest of the next guy knowing what is wrong, it looks like this was all the result of it being a 2nd hand unit. Found settings buried in the advanced parameters tab for the mounting orientation of the APM and of course it was set to 180 deg. Reset that to 0 and it flies with the APM mounted the right way round, and the HUD makes sense now. Then discovered thru various discussions on this board and others, that the pitch channel always needs to be reversed on these things. Again found a setting for channel 2 input reverse, turned it on, and voila all now works as it should. I cannot imagine why the last guy had it set this way. But there we are.

Im sure you guys will say “should have read the wiki” but I have thus far found it to be better than some, but by no means exhaustive. Seems to gloss over LOADS of settings, and didn’t mention any of this. And of course it written for mission planner and not APM planner 2.0 so even when I can find what i am looking for, its telling me to look in menu’s I don’t have. I can only assume that over time it will be rewritten and this will improve…

anyway, problem solved and it is now working, time to get busy balancing everything…