Arming problems and strange behavior

Hello everyone!

I’m having some problem with my Ardupilot APM. It goes more or less like this:
I Try to arm the drone the red blue light start alternating and all the engines start spinning but after a short while they all stop. I do not have throttle controll at this point. When I put the drone in ESC program mode I can reprogram them and the drone will listen to the trottle but it will roll towards it’s right. It’s hard to tell if it’s not tipping-over. I tried recalibrating the compass and tried taking it outside just to be sure. The log says this:

Log File C:/Users/Kuba/AppData/Local/Temp/tmpAC4A.tmp.log
Size (kb) 15.8994140625
No of lines 452
Duration 0:00:00
Vehicletype ArduCopter
Firmware Version V3.2.1
Firmware Hash 36b405fb
Hardware Type
Free Mem 0
Skipped Lines 0

Test: Autotune = UNKNOWN - No ATUN log data
Test: Balance/Twist = GOOD -
Test: Brownout = GOOD -
Test: Compass = WARN - WARN: Large compass offset params (X:-120.00, Y:-166.00, Z:-286.00)
No MAG data, unable to test mag_field interference

Test: Dupe Log Data = GOOD -
Test: Empty = FAIL - Empty log? Throttle never above 20%
Test: Event/Failsafe = GOOD -
Test: GPS = FAIL - Min satellites: 0, Max HDop: 0.0
Test: IMU Mismatch = UNKNOWN - No IMU log data
Test: Parameters = GOOD -
Test: PM = UNKNOWN - No PM log data
Test: Pitch/Roll = GOOD -
Test: Thrust = GOOD -
Test: VCC = FAIL - VCC below minimum of 4.6v (4.541v)

I’m running EMAX BLHeli ESC’s

Hello again,

I still haven’t solved my problems, but I observed some perculiar behavior. I hope that maybe this could provide someone with an idea of what may be wrong.

While arming the drone connected to the PC via USB the drone starts to behave just fine and listens to the throttle. Upon disconnecting, after a couple seconds it behaves just like before and shuts down.

I furthermore tried recalibrating the compas in a different way and this didn’t help as well.

Does anyone have a clue what could be wrong? I would really appreciate your help.

Please don’t leave me grounden :wink:

I think that your flight controller is underpowered as shown by the Auto Analysis:
Test: VCC = FAIL - VCC below minimum of 4.6v (4.541v)

You may have a battery issue.


After a quick look I can see that -

Your battery failsafe is 13.8v which is fine for 4s but your log is using a depleted 3s battery so might not help.
Your vcc is a bit low at 4.5, non 3dr apm’s run as low as at 4.7-4.9v which indicates a possible problem with your power supply to the apm.
Your THR_MAX parameter is only 80 and should be 1000.
Your Z compass offset is a tad high, would suggest raising your compass higher.

Hello again,

I would like to thank MarkM and TCIII for their help. I bought an power module BEC for the Arducopter, and an mast for the gps. I recalibrated the hole thing and put the voltage failsafe on 10.5V. Before I had put it on 11.5V but then it would disarm itself after 5 seconds of ruther listening

This is the wideo of it’s first flight (it’s windy and the drone requires some axcel calibration): … 8461489670

Anyway, thanks again and best regards!